Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install proprietary ATI Catalyst drivers on my Ubuntu 12.04.1. Every driver on AMD's website says it requires glibc version 2.2 or 2.3. Upon running the ldd --version command, I have learned that I have version 2.15.

Does 2.15 include 2.2/2.3? If it does not, what can I do? Can I install that library alongside 2.15?

share|improve this question
Since 2.15 > 2.2, I guess you are covered. But don't take my word for it and wait for someone with experience to answer. In the meantime, add your graphics card model to the question. – edwin Mar 23 '14 at 4:16

Well, after successfully installing Catalysts 12.1 through 12.10, I have learned that GCC 2.15 DOES cover the 2.2 / 2.3 requirement for Catalyst and addition files are not needed for THAT, so consider this SOLVED.


I tried drivers 12.6 through 14.3 on an installation of Ubuntu 12.04.4 and none of them worked. Then I learned that the extra ".4" made all the difference and I in fact had an X server and Kernel later than I thought, which would have caused issues for at least the older drivers. So, I installed a copy 12.04.01 and was successful with drivers 12.1 - 12.10. I chalked the problem up to incompatibility and inexperience.

Then, I remembered that after 12.4, AMD dropped future support for my HD4250 card in Catalyst 12.6 and on. I have switchable graphics (the other is a 5470) so I thought maybe that is why the later drivers were not working...then I realized that I had installed drivers 12.6, 12.8, and 12.10 successfully, so simply having an HD4250 is not the problem.

I reiterate: 12.1 - 12.10 work with Ubuntu 12.04.01 with X server 1.11 and Kernel 3.2. on my Acer Aspire 5553g with switchable AMD Mobility Radeon's HD 4250 and HD5470. Everything above 12.10 will not work, despite the fact that I compatible hardware, a viable kernel and x server, and all the necessary software.

Or, do I? Do I now need to UPGRADE all that stuff for, say, 13.1 - 14.3 to work?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.