Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.



I have a problem connecting to the internet using Ubuntu 12.04
I'm trying to connect to my home router/ap using my Lenovo T530 . Every other device works just fine on the WiFi. Also, my T530 works just fine on all and any other WiFi except mine. It's not a router issue, I've triple checked.

I attached data for both connections. One shows data from "BlackXs", my WiFi that doesn't work. The other screenshot is done on the same device just seconds later, on another WiFi named "arbo" (my brother's connection up in the attic) working just fine.

Can anyone explain or offer a solution?

Working:

root@t530:/home/augustin# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr a4:4e:31:4f:ac:4c  
          inet addr:192.168.1.8  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::a64e:31ff:fe4f:ac4c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13557 errors:0 dropped:1 overruns:0 frame:0
          TX packets:18810 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:11021816 (11.0 MB)  TX bytes:1781840 (1.7 MB)

root@t530:/home/augustin# iwconfig wlan0
wlan0     IEEE 802.11abgn  ESSID:"arbo"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 7A:D1:5E:12:36:D1   
          Bit Rate=1 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=28/70  Signal level=-82 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:5  Invalid misc:8   Missed beacon:0

root@t530:/home/augustin# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_req=1 ttl=64 time=49.5 ms
64 bytes from 192.168.1.1: icmp_req=2 ttl=64 time=1.74 ms
64 bytes from 192.168.1.1: icmp_req=3 ttl=64 time=99.2 ms
^C

Not working:

root@t530:/home/augustin# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr a4:4e:31:4f:ac:4c  
          inet addr:192.168.0.101  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::a64e:31ff:fe4f:ac4c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18396 errors:0 dropped:1 overruns:0 frame:0
          TX packets:24330 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14264964 (14.2 MB)  TX bytes:3038114 (3.0 MB)

root@t530:/home/augustin# iwconfig wlan0
wlan0     IEEE 802.11abgn  ESSID:"BlackXs"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 1C:7E:E5:01:0C:F4   
          Bit Rate=65 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70  Signal level=-26 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:13  Invalid misc:3   Missed beacon:0

root@t530:/home/augustin# ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
^C
--- 192.168.0.1 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2014ms
share|improve this question
    
Please edit your question to add details of your wireless device from the terminal command: lspci -nn | grep 0280 Thanks. –  chili555 Mar 22 at 21:25
    
Many thanks @chili555 Thank you for being prompt and being the firs to try and help out. Also this answer from you on another question worked as a charm askubuntu.com/a/279549/261002 > Please open a terminal and do: > > gksudo gedit /etc/modprobe.d/iwlwifi.conf A new, empty file will open. > Add one line: > > options iwlwifi 11n_disable=1 Proofread, save and close gedit. Reboot > and let us hear your report. > > shareedit answered Apr 9 '13 at 12:13 > > chili555 –  AugustinJ Mar 22 at 21:38
    
So are you solved? –  chili555 Mar 22 at 21:47
    
Yes. Posting now using the WiFi that you made work :D –  AugustinJ Mar 22 at 21:48
    
Awesome. Glad it's working. –  chili555 Mar 22 at 22:08

1 Answer 1

up vote 0 down vote accepted

Solution described here worked perfectly http://www.askubuntu.com/a/279549/261002

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.