Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like some help with this, please. Will be very glad is anyone will point me in the right direction. Thank you in advance! This is when the connection is present and browsing:

eth0      Link encap:Ethernet  HWaddr 50:46:5d:4a:9e:4f  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:2666 errors:0 dropped:0 overruns:0 frame:0
      TX packets:2666 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:228844 (228.8 KB)  TX bytes:228844 (228.8 KB)

wlan0     Link encap:Ethernet  HWaddr dc:85:de:1c:91:f9  
      inet addr:192.168.1.147  Bcast:192.168.1.255  Mask:255.255.255.0
      inet6 addr: fe80::de85:deff:fe1c:91f9/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:18780 errors:0 dropped:0 overruns:0 frame:0
      TX packets:12817 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:21198762 (21.1 MB)  TX bytes:1746891 (1.7 MB)

When connection goes:

wlan0     Link encap:Ethernet  HWaddr dc:85:de:1c:91:f9  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:209503 errors:0 dropped:0 overruns:0 frame:0
      TX packets:132560 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:268811733 (268.8 MB)  TX bytes:15479814 (15.4 MB)
share|improve this question
    
I've added 8.8.8.8 to additional DNS servers (was proposed as a solution on one of the threads), will see if that helps. –  user261007 Mar 22 at 22:24
    
You're losing your IP address itself. Assuming you are using a router, is the registration period long enough (24 hours or so)? –  saiarcot895 Mar 22 at 23:38
    
Adding an additional DNS server isn't going to help your situation, at least not the main problem. You are losing your IP address from your router. Is your router set up to automatic for the channel? If so change it to a set channel. Have you tried going into your router and setting a static DHCP reservation so that your router gives the same IP to your device based off of its MAC? Have you tried to manually configure your interface instead of using DHCP? What version of Ubuntu are you using? If these things above fail, can you post an output from your syslog and dmesg as the device fails? Sor –  user261580 Mar 24 at 13:55

1 Answer 1

I have had the Same problem, and you can from the terminal type:

 lsmod wlan0
 lsusb -s wlan0
 nmap --spoof-mac dc:85:de:1c:95:ft
 nmap -v -iR 10000 -Pn www.google.com

it might work fine this way.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.