Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed ubuntu 12.04,without nvidia driver I can use my Laptop screen and a second screen over the HDMI port of my laptop.

For some reason when I install the nVidia driver 331.20 the second screen which is using the HDMI port is getting a mirrorscreen of my Laptop. The nVidia driver also doesn't recognize the second screen. But when I enter the ubuntu display setting it show both screen overlapping each other. When I try to put on screen beside the other one and click on apply, both screens turn black and I get logged out but both screens are still mirroring.

Anyone got a pointer for me how I could fix this? If any logs needed to better trace my Issue please tell me as I'm new to unix/linux.

E: My graphic card is a GT 630M

share|improve this question
Have you tried / do you see the TwinView option? – nutty about natty Mar 31 '14 at 6:31
Have you tried / do you see the TwinView option? ... Maybe it could help prod things further..? – nutty about natty Apr 2 '14 at 20:18
Do you see a check box that says Mirror Displays? Or have you checked Nvidia X Server Settings to see if Twinview is enabled, like nutty about natty said? – ChrisR. Apr 2 '14 at 20:25
I'll check tomorrow – Johnny000 Apr 2 '14 at 21:32
are you working with the repository driver or you had install the propertary ( I had experienced a lot of trouble with nvidia propertary and not so much improvements. you can try by installing arandr and manage the monitor from that. – adexmont Apr 3 '14 at 11:28

You can get a lot of information from /var/log/Xorg.0.log. Look for Errors.

Also check out /etc/X11/xorg.conf. xorg.conf used to be necessary for setting up X properly, but my experience has been that it usually gets in the way now.

I have a newer version of Ubuntu and a newer graphics card, but I run without any xorg.conf file and don't use the nvidia-settings tool at all any more. Instead I can just use the standard displays applet.

If you must use xorg.conf, I find the displays applet only gets in the way. In this case I suggest deleting the display config for your user and instead use the nvidia-settings as root to set the monitor config. Note that setting the monitors this way makes it a pain when docking and undocking a laptop. Since you are using a laptop I highly suggest trying to run without xorg.conf defined (make sure to rename it instead of deleting it, so you can put it back if there is a problem).

Good luck

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.