Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Showing message:

E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
share|improve this question

marked as duplicate by Radu Rădeanu, Eric Carvalho, Avinash Raj, Aditya, chaskes Mar 28 at 21:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

Probably you did not use 'sudo' before your command in the terminal. That is why it tries to imply that you are not root.Try this:

sudo apt-get update

Then you will be asked for the password. Type it and press enter. Your update will start. Also note that when you type the password the * or the dots that appear normally when you type the password wont appear. Just type it without errors and press enter.

share|improve this answer

You have to be a root in order to update your sources list.

To do that you can use a fantastic utility called sudo.

Easily run the update command using sudo before

sudo apt-get update

sudo allows a permitted user to execute a command as the superuser or another user, as specified by the security policy. The real and effective uid and gid are set to match those of the target user, as specified in the password database, and the group vector is initialized based on the group database (unless the -P option was specified).

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.