Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My mainboard hast two ethernet ports

So far i have only used one (eth1), which is connected to a router with a dhcp-server.

However, I want to use the other port (eth0) simultaneously to connect to another wlan router. The desktop is supposed to act as a hub, i.e. forward the dhcp services and all packages to the wlan, while still being a client in the network itsself.

  • Is there any tutorial on this topic? (I couldn't find anything useful on google)

So far I am using a static ip setup for the wlan router (eth0). As soon as I simply plug in the cable and connect with the network-manager, the internet connection is lost (even though the network manager shows, that both networks are connected). It appears that by default eth0 is then used for communication.

  • using firefox or any piece of software, (how) can i control which network interface is used individually and by default?
share|improve this question
possible duplicate of How to set up dual wired and wireless connections? – Sneetsher Mar 22 '14 at 10:16
Thanks! I tried to follow the advice from the linked Question: I checked the "Use this connection only for resources on its network" in the Routes Dialog for eth0. however, as soon as I turn the interface on, I cannot ping any ip anymore (neither of both routers). – IARI Mar 22 '14 at 11:36
To make sure, You are using different IP subnets for the two networks? Could add DHCP server or static IP setups used for both networks to the question. – Sneetsher Mar 22 '14 at 11:43

You can temporarily disable the unwanted interface - ifconfig eth0 down. Otherwise, if you want an interface disabled by default you can add the same command to /etc/rc.local. I suppose you could also set up xbindkeys to disable interfaces with keystroke as well.

share|improve this answer
Thank you, but i need both connections to be enabled simultaneously. – IARI Mar 22 '14 at 11:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.