Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 10.04 OS and a virtualbox (not the OSE) with windows XP as a guest.

When I choose Full screen in virtualbox the operating system (my guest, windows XP) is still in small screen.

I installed the guest additions. However, if I go to Devices on the Menu, it still shows "Install guest additions" like they were not installed. I can only choose 800x600 and 600x480 resolutions.

I'm using VB 3.2.8.

These are my settings:

General
Name: windowsxp
OS Type: Windows XP

System
Base Memory: 512 MB
Processor(s): 1
Boot Order: CD/DVD-ROM, Hard Disk

Display
Video Memory: 24 MB
3D Acceleration: Enabled
2D Video Acceleration: Enabled
Remote Display Server: Disabled

Storage
IDE Controller
  IDE Primary Master: windowsxp.vdi (Normal, 10.00 GB)
  IDE Secondary Master (CD/DVD): VBoxGuestAdditions.iso (32.01 MB)
Floppy Controller
  Floppy Device 0:Empty

Audio
Host Driver: PulseAudio
Controller: ICH AC97

Network
Adapter 1: PCnet-FAST III (NAT)

Serial Ports Port 1: COM1, Disconnected

It looks like windows XP is using the VitrualBox Graphics Driver (Device manager > Display adapters : VirtualBox Graphics driver) It just doesn't show in full screen mode..

share|improve this question
    
Does Scale Mode option helps? –  penreturns Oct 7 '12 at 10:52
add comment

5 Answers

Gues additions seem to been installed correctly.

Can you give your graphic card 32 Mb of memory. It's the only difference that I see with my setup that does work correctly in fullscreen or seamless.

How to check if video guest additions are installed

Looks like guest additions have not been correctly installed. Check that windows is using Virtualbox Graphics Adapter as it's display driver. If it isn't try to reinstall the guest additions and report back any problem that it displays.

You can check it using the Device Manager on windows. If you are using XP, you can reach it this way:

  • To open Device Manager, click Start, and then click Control Panel. Click Performance and Maintenance, and then click System. On the Hardware tab, click Device Manager.

Other windows version have it placed in another places, but it's always there ;).

share|improve this answer
    
I will check this out, thx already. –  eddy147 Sep 20 '10 at 7:47
    
I can not find anything in VB about VirtualBox Graphic Adapter. I updated my post with my VB settings –  eddy147 Sep 20 '10 at 16:28
1  
Sorry, you should check in the virtual windows, in the Device Manager. How to reach it depends on the windows version. From Microsoft documentation: To open Device Manager, click Start, and then click Control Panel. Click Performance and Maintenance, and then click System. On the Hardware tab, click Device Manager. –  Javier Rivera Sep 20 '10 at 17:20
1  
Yep, right-click on the Windows XP desktop, choose Properties, then choose Settings. It should say "Default Monitor on VirtualBox Graphics driver". I've given my Windows XP VM 1Gb RAM and 128Mb of Graphics memory, but otherwise my settings are identical to yours. I'm also running Meercat 10.04 on a Toshiba laptop using Intel GMA4500 graphics, although I believe that's irrelevant. –  Scaine Sep 20 '10 at 18:30
    
Ok, it looks like windows XP is using the VitrualBox Graphics Driver (Device manager > Display adapters : VirtualBox Graphics driver) It just doesn't show in full screen mode... –  eddy147 Sep 23 '10 at 19:04
show 1 more comment

The important thing for client screen resolution is to install the vbox client tools. after that yout virtual OS will change his own resolution by changing the vbox window size.

share|improve this answer
add comment

AFAIK, there's a bug in linux-headers that prevent guest additions from working properly.

Run this command first:

sudo apt-get install linux-headers-`uname -r` build-essential dkms

Then install the VB guest additions.

Hope this helps.

share|improve this answer
    
This is only needed for a linux guest, AFAIK. –  Javier Rivera Sep 20 '10 at 10:00
    
Aah, right. Ignore me then :) –  Mat Tomaszewski Sep 20 '10 at 10:03
add comment

after install "VirtualBox Guest addition" [1] http://i.stack.imgur.com/JF9Gz.jpg

open General > Advanced. here you can choose between various Shared Clipboard settings: Bidirectional

share|improve this answer
add comment

The install guest additions doesn't change after install.

As for your resolution, have you tried installing all drivers that would normally be needed for your system? Im not sure how virtualbox works exactly, but im guessing it 'clones' the host system...

share|improve this answer
    
You don't need host drivers in a guest system. –  Javier Rivera Sep 20 '10 at 7:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.