Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i can't watch flash content in firefox. can someone please help me?

I am sorry if this has already been addressed, but i have visited numerous forum posts and tried several different things.

My computer is a compaq presario 2195US. The processor is athlon xp 2500+ OS is lubuntu, 13.10. I had to install it via the alternate installer because for some reason the normal lubuntu installer didn't work. I had a black screen with the little thing going around and around forever.

Once i installed lubuntu, i opened firefox and tried to watch flash stuff on youtube. The page loaded but the player did not show up...that part of the screen was blank.

I then tried watching a youtube video which i knew was html 5, and that worked. (vihart pi rant)

So I installed lubuntu-restricted-extras.

After that, i couldn't watch any youtube videos at all, not even html5.

Then i tried installing flash directly, using the terminal (same way i installed the restricted extras) and it said could not find the specified flash package, and then i tried it a different way and it said the flash package was already installed. I guess that was due to the restricted extras which i had already installed.

I then tried installing chrome 19, but that did not work...it said failed to satisfy dependency libuv0 or something. SO i installed libuv0 from some link, and tried to install chrome again, and then the installer just crashed.

Then i went to https://support.mozilla.org/en-US/questions/964567 and tried following the instructions. It was weird because it told me to put the .so file in usr/lib/mozilla /plugins but i didn't have such a folder

my user name is herb, and i did not have a /herb/lib/mozilla/plugins folder either...so, i made /herb/lib/mozilla/plugins and put the .so file in there (with the name of the file changed as they recommend)...still couldn't play flash though ...btw i did use ctrl+h when looking for that folder

as you can see i am very confused. Your help would be much appreciated by me and my 5-year old daughter. I am doing this so she can do her kids educational websites like starfall, which requires flash. However, i am also doing this because it's fun! I think i am close to being able to do what i want.

BTW, before lubuntu i had ubuntu 12.04 on here. I just switched so it would be faster.

Another random fact: the computer was shutting down randomly, but i think it was because i was accidentally blocking the intake vent for the processor fan. Now that i am not blcoking it anymore, it's not shutting down randomly.

share|improve this question
    
Chrome 19 is very old. The current version is Chrome(ium) 32. Also, in the Mozilla instructions, it was referring to the folder named usr, not your user name, –  saiarcot895 Mar 21 at 11:57
    
thanks saiarcot895...i didn't understand the directory tree...now i see the folder it's talking about, although it won't let me put the .so file in there, said permission denied...maybe i'll try it via the terminal...oh never mind, i can use tools-open current folder as root –  user260501 Mar 22 at 9:15
    
Wow! thanks saiarcot...once i pasted it in, flash started working...you people rule! i am totally stoked...i have been working on this for weeks (also took a long time to install ubuntu due to a bad cd drive) and i finally can do what i want! with a free OS! yay!!! –  user260501 Mar 22 at 9:32

1 Answer 1

Follow this method to solve your problem:

  1. Open LXTerminal window.
  2. Type this following commands at your LXTerminal window:

    sudo apt-get update && sudo apt-get install flashplugin-installer -y

  3. Wait until the installation process is finished, if the process is finish. Close your terminal window and try tested the plugins at Chrome or Firefox

Note: If this method won't work, try this commands and repeat my method:

sudo apt-get install lubuntu-restricted-extras
share|improve this answer
    
Thank you FirstStrike for your assistance. I ran that command, then closed the terminal and launched firefox. I went to youtube and i still can't watch any videos, html5 or not. I tried speedtest.net and starfall as well. The first time I launched firefox and clicked a youtube video after running your command, i did get a popup that said there was a problem with firefox. But the next time i openedfirefox i did not get the popup but i still couldnt watch any videos. That part of the screen is just blank. I would try chrome but i had trouble installing it...should i try gnash or lightspark? Thnx –  user260501 Mar 22 at 8:04
    
@user260501 I edit my answer –  FirstStrike Mar 24 at 1:30
    
@user260501 And please mark this answer as accepted answer if my method is work –  FirstStrike Mar 24 at 3:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.