Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to transfer files (photos and audio mainly) from my phone, to my Ubuntu PC. Unfortunately upon plugging it in (through Micro USB) nothing is automatically mounted. If I insert a memory card into the phone, then that is automatically mounted.

There is software I can run on Windows XP that allows me to transfer files (although it does not make the phone show up as a volume in Windows Explorer).

The phone is a 3 Skypephone S2 (manufactured by Amoi). Everything I find on the internet suggests it should have a mass storage mode. When connnecting the phone to the computer a "PC Suite" mode can be enabled, however this does not seem to make a difference.

I tried to install the Windows Software through Wine, however this didn't work. (Probably unsurprising that Wine doesn't help with hardware related problems.)

I looked at this page but was unable to get "1614:0407", although I doubt that it would have helped if I had been able to.

Running udisks --mount /dev/sr2 gives me a 'CD' with some Windows driver files. If I run sudo usb_modeswitch --default-vendor 0x1614 --default-product 0x1000 then this goes 'CD' away, but I do not get access to the phone's memory.

Below are the new entries in dmesg when the phone is connected. Entering PC Suite mode does not cause any more messages.

[  683.140030] usb 7-1: new full-speed USB device number 2 using uhci_hcd
[  683.312734] scsi8 : usb-storage 7-1:1.0
[  684.317071] scsi 8:0:0:0: CD-ROM            S2       Driver CDROM     2.31 PQ: 0 ANSI: 2
[  684.331067] sr2: scsi3-mmc drive: 0x/0x caddy
[  684.331241] sr 8:0:0:0: Attached scsi CD-ROM sr2
[  684.331799] sr 8:0:0:0: Attached scsi generic sg9 type 5

When plugging in, I get the following extra entries in /dev:

lrwxrwxrwx  1 root root           3 Feb 29 18:22 cdrom2 -> sr2
crw-rw----+ 1 root cdrom    21,   9 Feb 29 18:22 sg9
brw-rw----+ 1 root cdrom    11,   2 Feb 29 18:22 sr2

Below is the output from lsusb:

Bus 007 Device 003: ID 1614:1000 Amoi Electronics 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x1614 Amoi Electronics
  idProduct          0x1000 
  bcdDevice            0.00
  iManufacturer           1 
  iProduct                2 
  iSerial                 3 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           32
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass         8 Mass Storage
      bInterfaceSubClass      6 SCSI
      bInterfaceProtocol     80 Bulk (Zip)
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x84  EP 4 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x05  EP 5 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
cannot read device status, Operation not permitted (1)
share|improve this question
    
@fossfreedom I'd never thought of that before! –  8128 Feb 23 '12 at 9:27
    
any messages (dmesg) when you plugin your phone into the PC? I dont know what PS Suite mode is - but again if you switch to "PS Suite" does any messages appear in dmesg? –  fossfreedom Feb 23 '12 at 20:47
    
@fossfreedom I've updated my post with some promising messages –  8128 Feb 24 '12 at 16:44
    
... hmmm - I've read around this - the USB appears only to offer a modem on MAC and Windows. The dmesg results confirm this - there is no mass media recognition. Possibly you could use bluetooth to do your file transfer. However I think you are out of luck with this phone in linux for mass media support. The PC Sync software appears to be windows only i.e. its proprietary. I'm out of ideas. I hope you find your answer :) –  fossfreedom Feb 24 '12 at 22:57
    
I gonna start smiliar question, very good this one, I hope we get more good answers with UBUNTU. –  H_7 Feb 26 '12 at 21:53

5 Answers 5

It looks like they are using that silly trick where the device pretends to be a cdrom to get windows to autorun a program to install their software ( since windows foolishly won't autorun from usb mass storage ).

You might look at the usb-modeswitch package and see if it can flip the device into mass storage mode.

Further information from the authors web-site.

share|improve this answer
    
+1 sounds entirely plausible. hope this works for the OP. –  fossfreedom Feb 26 '12 at 21:48
    
Unfortunately, this doesn't seem to work. But that may be me not being able to "guess" the correct parameters. Running sudo usb_modeswitch --default-vendor 0x1614 --default-product 0x1000 doesn't make any difference. –  8128 Feb 27 '12 at 18:46

I am not sure if the device is using MTP mode or not... if it is you can try this:

sudo apt-get install mtpfs

Create a UDEV rule file. Use your editor of choice, mine is nano.

sudo nano /etc/udev/rules.d/51-skyephone.rules

add one line to it:

SUBSYSTEM=="usb", ATTR{idVendor}=="1614", MODE="0666"

create a mount point and make yourself the owner:

sudo mkdir /media/skyephone

sudo chown user:user /media/skyephone

then you can test to see if mounting works:

sudo mtpfs -o allow_other /media/skyphone/

If you can access files now this worked.

to unmount:

sudo umount mtpfs


You can also try mounting the CD device (I know it is not really a CD device)

udisks --mount /dev/sr1

or if your computer has no internal CD/DVD-ROM

udisks --mount /dev/sr0

share|improve this answer
    
Could not display "/media/skyephone". Error: Error when getting information for file '/media/skyephone': Transport endpoint is not connected. Please select another viewer and try again. –  8128 Feb 28 '12 at 16:38
    
[That's from Nautilus] –  8128 Feb 28 '12 at 16:38
    
fluteflute: the phone might not be MTP enabled then. –  cprofitt Feb 28 '12 at 17:34
    
udisks --mount /dev/sr2 mounted the "CD device" which gives me a set of drivers, but not my files –  8128 Feb 28 '12 at 17:37
    
when you plug in the device do you get any additional devices listed in your /dev/ folder? When I add a USB stick I get an SDB and an SDC, etc... –  cprofitt Feb 28 '12 at 23:26

Okay first off, use apt-get in terminal to get a virtual box if you don't have one already and install a windows XP OS .iso on it. If you don't have the .iso, you know where to get one ;). Once it is install, install the extensions pack for it and you should be able to install the program for your phone in the virtual machine and access your phone through it as well after you select it in on the 'devices' > 'usb' drop-down menu. If you have issues after doing this, let me know.

share|improve this answer
    
wow, what a shot... let's see some results... –  H_7 Feb 26 '12 at 21:54
    
...Not entirely sure what you are trying to say, but I can tell you're being negative. I suggested an easy, straight-forward way to access a phone that uses a windows executable program to access it. I did not assume that he need more help than this. I did assume he'd ask if could not figure where to go from there. Please do not bash other people's comments just to troll. Wine is not compatible with my Samsung suite, and I doubt it would be with the Skypephone suite. Linux is not Windows and it never will be. Some applications will never work with Linux because they are not made for Linux. –  PyroSamurai Sep 4 '12 at 22:13
    
By the way, what I suggested to him worked for my Samsung PC Suite, the results are in the fact that my phone files are now on my PC. The question is if he trying to get to files on his phone or if he is determined to find a way to do it with Ubuntu. –  PyroSamurai Sep 4 '12 at 22:21

Assuming that this is a multi-mode USB device, which is common these days. You will probably have to create a new UDEV rule that filters that device and then runs usb_modeswitch, which if successful, will present the secondary mass storage device. At which point UDEV will just work and the desktop will have what it needs to automount it like everything else.

The first step is troubleshooting usb_modeswitch and verifying which switches actually present the flash device you're looking for. After that, the UDEV rules are basically boilerplate changes and you're done. lsscsi is a helpful tool that consolidates the listing of all low level storage devices on your system and is easier than constantly checking dmesg for a new drive being detected.

share|improve this answer

I am taking path of least resistance, try this:

After connecting the phone to the PC via the USB cable (the one from the charger), pull down the white bar at the top of the screen, tap the "USB connection", then tap "USB Mass Storage". Then tap OK. The device should mount automatically on most systems and be visible via your PC system file manager.

share|improve this answer
1  
Tapping is going to be hard as my phone does not have a touchscreen! Or a white bar at the top of the screen. Or inded anything there can be pulled down... –  8128 Feb 29 '12 at 15:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.