Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an acer aspire 5742g. My battery life is not good at all. I bought a new battery(not original) and my battery life is about 1h and 40 minutes. With the last battery I had(the original one) my battery life was about 30 minutes. TLP is installed and I have the closed source nvidia drivers installed. Any ideas what can be wrong??? I have Ubuntu 13.10 64bit with Unity. Those times where while using firefox or chromium, skype(logged in but not using it), dropbox and ubuntu one. P.S. I know that there is a serious chance the problem to be with my battery but I still want to know if there is any other problem and if it is possible to find out what is it.

share|improve this question
    
Canonical said that the version 14.04 this April, will have many improvements concerning battery life... So, wait one month :D –  Dusan Milosevic Mar 20 at 13:24
    
It's also dependant on what you are doing. Battery benchmarks are usually done with the computer practically hibernating. Wifi, virtual box, 3d, and anything that consistently loads the processor will cause an increased drain on power. –  bleeves Mar 20 at 16:07
    
I know but comparing with laptops of other people it looks weird.... So there is no way to find out what is the problem? –  Orestis Mar 21 at 7:36

1 Answer 1

You have a usual problem with Nvidia Optimus technology. Search Internet for solutions that would fit you, for there are many. If you are not gaming, just disable nvidia card.

share|improve this answer
    
i red somewhere that the 319 drivers already have the optimus technology native.... –  Orestis Mar 21 at 7:35
    
Due to the number of people with problems, I think Nvidia will never actually fix that. BTW Ubuntu 13 default driver is 304. –  Barafu Albino Mar 21 at 18:35
    
OK I installed bumblebee. I run sudo nvidia-xconfig but I get command not found. Now I have a very resolution. What should I do? –  Orestis Mar 22 at 13:40
    
Sorry, that I don`t know. My users always preferred using nvclock to poweer doun nvidia manually. –  Barafu Albino Mar 22 at 18:44
    
I unistalled everything that had to do with nvidia and re-installed the 319 drivers.... No it is ok... But still do not have bumblebee –  Orestis Mar 25 at 7:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.