Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently got a new HP Pavilion 17 with Windows 8 on it and decided to install 13.04 (LTS, IIRC) on it as a second OS. The install seemed to go smoothly but now I'm finding out that it's not recognizing my normal Wi-Fi connection; it doesn't even see it, in fact. I am at least able to use a wired connection, but I'd really like to be able to use my Wi-Fi as much as possible.

I also tried sudo rfkill unblock all, and that didn't work, either.

Also, if any of this helps:

  • The laptop does not have any physical Wi-Fi switches to my knowledge.

  • This computer came with an UEFI BIOS configuration.

  • I used the wired connection during a couple of Live Sessions and while I was installing the system. Could this have caused a problem? (seems unlikely to me though I didn't think it would hurt to ask).

  • I seem to have a RealTek network controller. When I ran lscw -C network, it also mentioned that something was "unclaimed":

 

  *-network UNCLAIMED     
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: latency=0
       resources: ioport:3000(size=256) memory:f0200000-f0203fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: eth0
       version: 07
       serial: a0:d3:c1:65:dd:17
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8106e-1_0.0.1 06/29/12 ip=192.168.0.17 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:47 ioport:2000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff memory:f0400000-f040ffff

(should note that I didn't run it as a superuser, though)

lspci tells me this:

steven@steven-HP-Pavilion-17-Notebook-PC:~$ sudo lspci -nn | grep -E 'Net|Eth'
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:8179] (rev 01)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader [10ec:5229] (rev 01)
05:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 07)

"Unassigned"?

I'm going to keep trying to look for solutions, but in the meantime if anyone can give me some clues as to how to fix this, I'd appreciate that. =)

share|improve this question

closed as off-topic by Florian Diesch, Radu Rădeanu, karel, Warren Hill, BuZZ-dEE Mar 20 at 18:20

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

up vote 0 down vote accepted

I'm afraid you're up against a known bug, click on the link for more information.

The bad news is that there is probably no way to get it working on your system. The good news is tat it should work out of the box on the newer 13.10:

I just booted the latest daily build of the Ubuntu 13.10 Desktop 64bit (Alpha) live CD, and wi-fi worked perfectly on the Lenova IdealCentre Q190 Model 57312246.

So, according to the bug report, this has now been fixed and should work fine on any version of Ubuntu from 13.10 onwards.

share|improve this answer
    
Thanks for the tip, terdon. Wish me luck. =) –  AlternateSteve90 Mar 20 at 4:26
    
Yes, it did work and I have clicked the check mark. Thanks for the help, very much appreciated. =D –  AlternateSteve90 Mar 20 at 6:01

See for help option and for internet connections. My dongle was also not getting started. I saw the help options in mu ubuntu 10.04 it worked.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.