Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I built my own PC and have been struggling to get Ubuntu 12.04 installed on it.

I have a 16 GB RAM machine with an Asus M5A99FX PRO R2.0 motherboard, an AMD FX8350 processor and an AMD R9 270x graphics card. I have Windows 8 installed on a SSD but since this has been such a problem, I have only got a 160GB HDD attached to isolate it.

When I boot from a Live CD it sometimes loads and lets me install Ubuntu. When this occasionally happens I install Ubuntu and when I go to boot on the generic mode I get a purple screen. Additionally, when I boot in recovery mode it hangs on a blackscreen saying

switched to clocksource tsc.

I have tried the nomodeset kernel modification and made sure that secure and fast boot is disabled in the bios. Does anyone else have similar problems or similar hardware that could help me at all?

I am relatively new to linux in general and I am all out of ideas. It goes without saying that I appreciate any help I can get.


So I eventually started to try different distros to try and get this to work. I found that out of the popular distros, linux mint worked for my machine.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.