Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my system to 13.10 from 13.04 and lost all the applets in the normal view of my desktop (I see that they are active when clicking on the workspace switcher, see this image:

enter image description here

I remember that when I did that last time, upgrading from 12.04 to 13.04, I could not see my applets when I briefly started X in 12.10. I thought, no matter, I'll upgrade to 13.04 first and then look for a fix if necessary. It was not necessary, the applets were back in 13.04.

However, this time there is no upgrading to 14.04 yet and I was wondering if someone knew what package would need to be reinstalled to fix the problem. I am thinking that just by reinstalling something it will help. There are two reasons for that: (1) it worked for me from 12.10 to 13.04, and (2) I got such a response from the Ubuntu forum.

However, what was proposed so far has not worked.

What I'm wondering, also, is whether there could be logs about the problem and if so, where those logs are?

Could it be related to the theme I'm using?

share|improve this question

1 Answer 1

Wow! I found out how to get my applet back. I will have to see what happens on next reload/reboot but the window is definitively here, only it is behind another window, consistently.

First, list all your windows in a console screen as in:

wmctrl -l

That gives you a list of windows as follow:

0x01c00003  0 halk Top Expanded Edge Panel
0x01c00015  0 halk Bottom Expanded Edge Panel
0x01800029  0 halk alexis@halk:2014 8
0x02400002  0 halk XdndCollectionWindowImp
0x02400005  0 halk unity-launcher
0x02200006  0 halk Desktop
0x02400008  0 halk unity-panel
0x0240000b  0 halk unity-dash
0x0240000c  0 halk Hud
0x04a000a0  0 halk upgrade - Lost all my applets last time I upgraded (to 13.10). How can I get them back? - Ask Ubuntu - SeaMonkey
0x04600055  0 halk Inbox - alexis@m2osw.com - Shredder

As we can see, wmctrl command shows the name of each window. Part of the list we see: unity-panel and Top Expanded Edge Panel. If you use the -G option as well:

wmctrl -l -G

You see the positions too (Geometry):

0x01c00003  0 0    0    1920 24   halk Top Expanded Edge Panel
0x02400008  0 0    0    1920 24   halk unity-panel

And as you can see those two windows are positioned at exactly the same coordinates: (0, 0), and have the exact same size (1920, 24).

The Top Expanded Edge Panel is the one we want above. The unity-panel is the one obstructing our panel applets.

wmctrl -i -r 0x01c00003 -b add,above

I use the -r option with the XID and not the window title because wmctrl has problems with window names. (see Why wmctrl doesn't work for certain windows?)

If you make a mistake and use the wrong XID, you can remove the above property using:

wmctrl -i -r 0x01C00003 -b remove,above

This may not be a permanent solution, but it works. All I'll have to do is run a script that finds the window and raise it. The problem probably comes from the order in which things are created when starting X-Windows.


There is a script one can use to specifically force the Top Expanded Edge Panel to the top:

#!/bin/sh
PANEL_XID=`wmctrl -l | awk '/Top Expanded Edge Panel/ { print $1 }'`
wmctrl -i -r $PANEL_XID -b add,above
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.