Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have no sound at all on my 10.04 system. I have tried to follow with no luck so far. The odd thing is that sound worked before I upgraded to 10.04.

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

lspci shows

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)

I tried this too but with no luck:

sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2

I am mystified.

share|improve this question
Are there any errors messages you could add? Is pulseaudio running (try with pulseaudio -vvv in a terminal)? – Takkat May 18 '11 at 15:18
Have you read the part about alsamixer? Most issues come from muted channels. – Lekensteyn May 18 '11 at 15:45
See my answer below. Since you get BIOS auto-probing, you need to try the latest Alsa (1.0.24), and if you still get BIOS auto-probing, you need to manually set the model. – user4124 May 18 '11 at 17:15

You are still using an old version of ALSA, 1.0.20-21 (it is shown in the alsa-info output).

Step 1

Install the latest ALSA for your distribution from the ALSA PPA:

This is ALSA 1.0.24. So you can keep your current version of Ubuntu and have the latest ALSA kernel module. Once you install the latest ALSA, reboot your computer.

Step 2

Test if sound automatically works. If it does not work, check to see if you still see the following message (by running alsa-info):

[    7.422678] hda_codec: ALC268: BIOS auto-probing.

If you still see this message, then ALSA does not know the details of your sound card, and you need to add these details yourself. I'll add details for this if it is still the case.

Step 3

So you still see the message about ALC268: BIOS auto-probing.

If that is the case, visit:

Check the section about ALC268. It is

  quanta-il1        Quanta IL1 mini-notebook
  3stack            3-stack model
  toshiba           Toshiba A205
  acer              Acer laptops
  acer-dmic         Acer laptops with digital-mic
  acer-aspire       Acer Aspire One
  dell              Dell OEM laptops (Vostro 1200)
  zepto             Zepto laptops
  test              for testing/debugging purpose, almost all controls can
                    adjusted.  Appearing only when compiled with
  auto              auto-config reading BIOS (default)

The auto-probing message means that the auto facility in ALSA did not identify the correct sound chip, and you will have to set it explicitly. Your options are quanta-il1, 3stack, toshiba, etc. Depending on your laptop brand, start with the most relevant models.

You need to:

  1. Edit the file /etc/modprobe.d/alsa-base.conf by running:

    gksu gedit /etc/modprobe.d/alsa-base.conf
  2. Add or (if it already exists) edit the line

    options snd-hda-intel model=XXXXXXXX

and replace XXXXXXXX with one of the available models. Restart the computer and check if the sound is fixed. Repeat until your try out all other models.

Once you find the correct model, you are done! But please report back to describe the next step which involves informing the ALSA project about your sound card. That way, your computer's sound may work out of the box in the next version of Ubuntu!

share|improve this answer
Thanks. I upgraded alsa and still get [ 7.565952] hda_codec: ALC268: BIOS auto-probing. I should say, there are a lot of alsa messages in dmesg too. See – Raphael May 19 '11 at 12:58
Slightly confusingly, alsactl says it is at version 1.0.22 now but cat /proc/asound/version Advanced Linux Sound Architecture Driver Version 1.0.24. – Raphael May 19 '11 at 13:07
I updated my answer with the next step! – user4124 May 25 '11 at 13:55

Open 'alsamixer' and 'gnome-volume-control' in a console

  • gnome-volume-control & gnome-terminal -e alsamixer

  • Channels like 'Master' 'PCM' 'Front' (or similar) should influence the volume level in gnome-volume-control. If that is not the case, verify the card in the 'Output Tab' of the volume GUI.

  • Muting Channel 'Front' or similar (with 'm' key) should also mute 'Master' and show 'mute' activated in gnome-volume-control.

  • Put Channels like 'PCM' 'Front' or similar at '100' (use arrows).

From now on only 'Master' will be relevant, when you change volume during daily work.

If that does not give you sound, I would face the fact of a regression. To verify that you would have to run a Ubuntu 10.04 Live CD, before filing a bug in Launchpad.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.