Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get an error glgeterror when I launch counter strike source. Normal counter strike runs fine, this is all through steam.

I've done some digging and I need to get newer opengl drivers, My laptop has GPU 945gm intel and 1.4 opengl from what I can see.

Here are the sites ubuntu forum and launchpad

I'm stuck at the /etc/X11/xorg.conf. Ubuntu 13.10 doesnt have this ?

Also from the graphics driver guide I'm not sure which of these I should be using

To force the use of gallium i915 driver:

$ LIBGL_DRIVERS_PATH=/usr/lib/dri-alternates glxgears -info

To force the use of gallium llvmpipe software render:

$ LIBGL_ALWAYS_SOFTWARE=1 glxgears -info

To force the use of old non-gallium software render:

$ LIBGL_ALWAYS_SOFTWARE=1 LIBGL_DRIVERS_PATH=/usr/lib/dri-alternates glxgears -info

Any help would be great

share|improve this question

1 Answer 1

to get the latest openGL 3.3 compliant drivers and all the latest updates for them you should install the oibaf ppa.

sudo apt-get install ppa:oibaf/graphics-drivers

run that from the command line or include the oibaf ppa as a update source in the software sources.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.