Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I purchased an new notebook wich has a pre-installed Windows 8 (upgraded to Windows 8.1).

Configuration:

  • UEFI
  • Secure Boot
  • SSD + HDD

I downloaded Kubuntu 13.10, prepared a bootable USB stick and made some free disk space to setup a dual-boot system.

In order to boot from the USB stick I had to turn-off Secure Boot and switch to "CSM" ("Compatibility Support Module"; Legacy mode)!??

Now in the "Prepare partitions" (manual) step of the installer, /dev/sda (HDD) is pre-selected for "Device for boot loader installation".

As far I can see, the EFI partition is /dev/sdb1 (SSD; fat32) however.

I tried

  • /dev/sdb1
  • /dev/sdb
  • /dev/sda

but I always get an error about "reserved bios boot area".

Now as I understand, this "reserved bios boot area" is not needed for UEFI. So what should I do?

share|improve this question

1 Answer 1

You've booted in BIOS/CSM/legacy mode, so the installer is trying to set up a BIOS boot loader, not an EFI/UEFI boot loader.

I recommend you go back and find a way to boot in EFI/UEFI mode. One thing that might help with this is using an EFI-only boot medium. Unfortunately, the Ubuntu installation discs are Frankenstein-monster conglomerations of half a dozen more-or-less incompatible different systems that are made to work, after a fashion, through technical trickery. The trouble is that, although this sort of thing works much of the time, it fails sometimes, and when it does fail it becomes harder to disentangle everything.

The easiest thing to try is likely to be to create a second USB flash drive with my rEFInd boot manager. Insert both it and the Ubuntu boot medium in your computer and tell the computer to boot to rEFInd. If you're lucky, it will present a boot option for the Ubuntu installer and that will work. I can't promise that luck will be with you, though; you may need to go digging through firmware boot options or take some other radical steps to get it to work.

Oh, and you may also want to read my page on doing EFI-mode installs. It doesn't directly address the problem you're having, but it covers a lot of potential EFI installation and boot problems.

share|improve this answer
    
This sounds really bad. I've installed Kubuntu and SUSE/OpenSUSE several times before and only had minor issues compared to this whole UEFI, Secure Boot issues. This feels like being thrown back some 10 years. Like this, non-techies will have no chance to install Kubuntu on new computers. Well, I will try some more things and come back then. Unfortunatly, this is not the only issue I currently have (the installer crashes all the time, too). –  Puce Mar 19 at 8:56
    
I have a ASUS G750JH with Aptio (UEFI). Is there any way I can convince it to boot from the USB stick in UEFI mode? –  Puce Mar 19 at 13:43
    
My ASUS motherboard produces a boot menu when I hit the F8 key at the earliest points of the boot process. Selecting the boot option for an external device with "UEFI" in the description boots in EFI mode. Note, however, that some tools for copying .iso files to USB flash drives trash the EFI data, so you may need to try another tool. The most reliable, in my experience, is to use dd to copy the image "raw." –  Rod Smith Mar 20 at 0:10
    
Thanks. I will try these tips. –  Puce Mar 20 at 9:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.