Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install a spectral analysis tool for Ubuntu, and thought Spectrum3d looked good.

I've tried following the install instructions. As far as I understand, I am supposed to write:

sudo add-apt-repository ppa:nadaeck/spectrum3d

in the terminal. It doesn't work. I get the following error message:

Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 128, in <module>
    ppa_info = get_ppa_info_from_lp(user, ppa_name)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 84, in get_ppa_info_from_lp
curl.perform()
pycurl.error: (7, "couldn't connect to host")

From my rudimentary understanding of linux, I should be able to write my sudo password here, but the characters I write are shown in cleartext. It never asks for my password

When this didn't work, I tried to download it from sourceforge and compile it, I also tried searching for it in the Ubuntu Software Centre, but I couldn't find it.

I downloaded the latest version and went to the folder and typed:

./configure; make; make install

I got the following output:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking whether gcc and cc understand -c and -o together... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GTK3... no
checking for GTK2... no
configure: error: GTK library (libgtk-2.0 or libgtk-3.0) is required
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.

So, how do I just get this program up and running on my system?

share|improve this question
    
The first error means that it wasn't able to connect to Launchpad, for some reason. Can you try it again? –  saiarcot895 Mar 18 at 12:59
    
Also, what version of Ubuntu are you using. –  saiarcot895 Mar 18 at 12:59

1 Answer 1

That PPA is too old, doesn't have packages available for 13.10 and newer, so you would need to compile the sources instead. You need some headers and tools to build the software:

sudo apt-get install aptitude
sudo aptitude install build-essential libgtk-3-dev libgstreamer0.10-dev libsdl1.2-dev

After this is done, you can run ./configure and build your packages as usual:

./configure
[...]
config.status: executing depfiles commands

configure: If you want to use gtkglext, its version should match the gtk version (gtkglext-1.0 for gtk-2.0, gtkglext-3.0 for gtk-3.0)

configure:      ******************************************
configure:      *  Gstreamer version ...............1.0  *
configure:      *  GTK version .................GTK-3.0  *
configure:      *  OpenGL support...................SDL  *
configure:      *  JACK support......................NO  *
configure:      *  MULTITOUCH support................NO  *
configure:      ******************************************

The only thing left is make && make install. I strongly recommend building a debian package instead, so you can upgrade/remove easily.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.