Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I currently have a dual boot system with 6 partitions on my 180GB hard disk (4 NTFS, 1 for swap and the other one ext4). Ive got WIndows 7 and Ubuntu 11.04 (upgraded from 10.10) installed.

The 11.04 installation is messed up right now: missing dependencies/ 2 fglrx installs/ i have to manually mount every drive in order to use it/plymouth extremely messed up... Anyway I spent hours and hours fixing stuff or making them worse.

I now prefer to do a clean natty install. The problem arose: The installer sees my hard drive as 180GB of unallocated space. It doesnt detect any partitions, any other OSs and my only option is to format my whole drive, but I cant do that with all the important files and such.

Is there some way I can just format the current Ubuntu partition and install Natty there? (causing the installer to properly see Windows partitions for dual boot of course)?

Heres a pic: enter image description here


Update! : I played around with parted in the terminal and tried to use its print command. Heres what I got: Error: /dev/sr0: unrecognised disk label I dont really know if its useful or something, Im just trying stuff.


BUMP? I have some more information. When using Disk Utikity from the LIVECD it does see my partitions!!! :OOO But strangely enough it does see two more unallocated spaces: one of 43GB and... i laugh every time I think of this.... and another 18 milion Terrabites of unallocated space. Clearly my HDD is messed up so I decided to delete at least one partition that I do not plan on using.(I thought maybe that a change in the physical drive will update the partition table or something) Another problem: That did not work and it gave me the following error: "Cant have overlapping partitions." I googled this and it looks like a very bad thing.... Like I might have to completely reformat my drive... And I most certainly do not want that...


output of 1st command:

1+0 records in
1+0 records out
512 bytes (512 B) copied, 0.000157283 s, 3.3 MB/s

output of 2nd command

mbr.bin: x86 boot sector; partition 1: ID=0x7, active, starthead 1, startsector 63, 69609582 sectors; partition 2: ID=0xf, starthead 254, startsector 69609769, 321091031 sectors; partition 3: ID=0x7, starthead 254, startsector 235577160, 71601705 sectors, code offset 0x63, OEM-ID " м", Bytes/sector 190, sectors/cluster 124, reserved sectors 191, FATs 6, root entries 185, sectors 64514 (volumes <=32 MB) , Media descriptor 0xf3, sectors/FAT 20644, heads 6, hidden sectors 309755, sectors 2147991229 (volumes > 32 MB) , physical drive 0x7e, dos < 4.0 BootSector (0x0)


The fdisk -l command wont do anything, I suppose it needs some parameters. Yes I cand boot into the other two OSs fine, I did try a check disk, and it did not solve anything.

EDIT: Stupid me, i didnt use sudo. Here are the results from sudo fdisk -l:

ubuntu@ubuntu:~$ sudo fdisk -l
omitting empty partition (5)

Disk /dev/sda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00220022

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        4333    34804791    7  HPFS/NTFS
/dev/sda2            4334       24320   160545515+   f  W95 Ext'd (LBA)
/dev/sda3           14665       19121    35800852+   7  HPFS/NTFS
/dev/sda5            4334       13516    73755828+   7  HPFS/NTFS
/dev/sda6           13516       14608     8775680   83  Linux
/dev/sda7           14608       14663      442368   82  Linux swap / Solaris
/dev/sda8           19122       24320    41760936    7  HPFS/NTFS

Ok I found something RAID related and I executed this command: sudo dmraid -E -r /dev/sda just to get this output: "no raid disks and with names: "/dev/sda" "

share|improve this question
    
It would help if you included some more information on your partition setup (e.g. by including the output from fdisk -l from a live session). –  Takkat May 18 '11 at 9:06
add comment

4 Answers 4

Solved it myself in the end. After quite a while. Found a setting in BIOS that allowed me to switch between IDE (active) and RAID. I set it on RAID and next thing I know I got my Ubuntu installed. Unfortunately, Windows wasnt installed with RAID drivers so after installing Natty I switched back to IDE and they both work just fine.

Thought somebody might want to know.

share|improve this answer
add comment

The "alternate" CD has a better partitioner than the live CD.
I found this by accident when I had two hard disks in the system and the live CD could only see 1 of them. The alternate CD managed to see both of them.

share|improve this answer
add comment

This partition table is strange: sda3 should be a primary partition (sda1-4 are usually reserved for primary partitions), but it's blocks are defined inside an extended partition (sda2).

It looks like your MBR and extended partition table is messed up to me.

You can use this two commands to find how your partitions are defined on the MBR:

sudo dd if=/dev/sda bs=512 count=1 of=mbr.bin
file mbr.bin

The output of the second command should give us more information.

share|improve this answer
add comment

If your installer cannot see the drive(s) then you could try this.. I am assuming you can boot another OS to write this message? If it is windows (and if you know how) get windows to do a chkdsk /f prior to booting this should fix a few issues... If you do not know how, post back here.

share|improve this answer
    
Can you please edit your answer to include the missing parts? –  Takkat May 18 '11 at 9:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.