Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I was trying to speed up my tiny laptop by switching off OpenGL using Compiz. I guess there were also whole bunch of related plugins got disabled in the process. Then I lost the entire GUI desktop interface.

Could someone please tell me how to get everything back through command line?


share|improve this question

marked as duplicate by Radu Rădeanu, chaskes, karel, i08in, Avinash Raj Mar 30 '14 at 16:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Can you type anything of this 1. ctrl+alt+t 2. ctrl+F2 – Registered User Mar 18 '14 at 8:09
After a few reboots, I could login to Guess session with GUI, but my own account can't even login. It will loop back to the login screen. – Saigon Mar 18 '14 at 11:07


  1. Switch to tty1 using Ctrl+Alt+F1

  2. Login to your user account

  3. And export your Display with

    export DISPLAY=:0
  4. Add opengl to Compiz active plugins list

    dconf write /org/compiz/profiles/unity/plugins/core/active-plugins "[`dconf read /org/compiz/profiles/unity/plugins/core/active-plugins | sed -r 's/(\[|\])//g'`, 'opengl']"

    Or reset the key to default

    dconf reset /org/compiz/profiles/unity/plugins/core/active-plugins

    If it didn't work, come back and reset all Compiz settings to defaults

    dconf reset -f /org/compiz/
  5. Restart graphical display manager after one of the dconf command above

    sudo service lightdm restart
  6. Switch back to tty7 (X graphic display) Ctrl+Alt+F7

Try login again.

However, Compiz ccsm applies changes instantly so may be it's a nice habit to make configuration backup before change.

  • Backup before change:

    dconf dump /org/compiz/ > compiz.dconf
  • Restore if things went wrong:

    dconf load /org/compiz/ < compiz.dconf
  • Sometimes it is helpful to monitor the changes: dconf watch /org/compiz/


share|improve this answer
Thanks. Reinstalled Ubuntu already but thanks for your help. Now I know how to switch between tty and reenable things in Compiz. – Saigon Mar 20 '14 at 6:32
Ok, I added some info which may help others with similar problem. – Sneetsher Mar 20 '14 at 8:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.