Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu kde plasma desktop. I first installed Ubuntu, and then I upgraded to Kubuntu and have been using both for over a year now. When I upgraded kdeplasmadesktop the cursor is visible on the login screeen but cannot be seen inside Kubuntu. I have tried typing:

sudo apt-get update
sudo apt-get install diste-gnome

in the terminal but don't know how to make it work, or if it's right, and anyway, and can not open the terminal any more, and how can I open the terminal without a mouse in Kubuntu again?

Thanks.

share|improve this question
    
If you have a mixed configuration (ubuntu/kde or gnome or...) may be this one: askubuntu.com/a/417411/16395 --- if it works say it so we can mark thsi as a duplicate –  Rmano Mar 17 '14 at 18:30
    
You say you've tried typing those commands in the terminal, then you ask how to open the terminal? –  Sparhawk Apr 6 '14 at 10:50

4 Answers 4

I'm not sure an update will solve it, but if you want to try, just press: Control + Alt + F6

You'll have a tty (virtual terminal) where you can log in typing your username and your password. There, you can try:

sudo apt-get update
sudo apt-get install --reinstall kdeplasmadesktop

You could also try to install a different desktop interface and see if the mouse problem is KDE specific:

sudo apt-get install ubuntu-desktop

or, more lightweight:

sudo apt-get install xubuntu-desktop

To go back, use Control + Alt + F7 or just restart the computer with:

sudo shutdown -r now
share|improve this answer
    
Hi. The cursor is still not there, and I also tried getting set org.gnome.settings-daemon.plugins.cursor active false. Thanks. –  Michael Mar 18 '14 at 14:53
1  
Why don't you try to change the cursor theme and see if that does the trick? –  darent Mar 18 '14 at 17:52

This one is caused by having gnome settings active. Try to change this with dconf-editor:

Go to

org/gnome/settings-daemon/plugins/cursor/active

change it to false

I hope it helps

share|improve this answer
    
I have no settings-deamon in org.gnome in Xubuntu 14.04 –  rubo77 Jul 26 '14 at 7:35
    
But I solved it with an old nvidia-driver: Invisible mouse on 14.04 with NVIDIA GeForce4 Ti 4200 –  rubo77 Jul 27 '14 at 5:20

I've had invisible mouse problems in all versions xubuntu 12.04, xubuntu 14.04, xubuntu 14.10, kubuntu 14.04 i386, all on an older (2006) single core 32 bit cpu 1024MB RAM with an older nvidia graphics card which was sufficient in ubuntu9.10 to do 1920x1080 px except that its nvidia-96 driver has been declared unavailable and the default gamma=0:0:0 is missing in xrandr and also missing in the nvidia configuration utility. There being a nasty gap of unknown shape in the configuration data instead of a sensible default gamma prohibits us from fixing missing screen modes (for some reason the nvidia configuration has one less screen mode each year ???). Installing the nvidia-96 driver fixed my missing mouse cursor in xu12.04 but lost all screen modes bigger than 480x320px, which is so Windows3.1 that it isn't funny. Generally, in about one in six installs a mouse cursor was white and working as usual and present from before login, and doing updates or upgrades lost it.

Ubuntu, please fix nouvau drivers so that the known-good ten year old hardware can be 'unbroken' after updates. Particularly, please fit nouvau with a sensible default gamma so that screen modes may be added with xrandr as in previous years.

share|improve this answer

xubuntu 14.10 and ubuntu 12.04 do not have a directory called org to start looking for the fix of Moga. any clues anyone?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.