Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have uninstalled Rhythmbox and installed Banshee. In Gnome-do there was this nice feature of browsing your music files with the Rhythmbox-plugin. So, on the Gnome-do plugin Wiki I could see that a Banshee-plugin exists.

On Launchpad, specifically on this site I downloaded a tar.gz, where I could also see a Banshee-plugin after unpacking. When I downloaded gnome-do-plugins via Software Centre there was no Banshee-plugin to activate in Gnome-do's preferences. So, is there any way I could install this plugin from that tar.gz or any other way to install it?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

If you have the source it usually contains README and INSTALL to guide you through installation process.

Basically untar the source and cd to the folder

./configure
sudo make
sudo make install 

is the most know way of building and installing from source.

Also some source may have install scripts like install.sh which would make it much more easier as in the case of above link. You may try running sh install.sh as well.

share|improve this answer
    
OK, now I have tried a different approach on another PC: First, I installed Banshee through Ubuntu's repositories, afterwards I installed Gnome-do. Et voilá - the Banshee plugin was there. Now I have tried to completely wipe Gnome-Do from my main machine and reinstall it from the repositories without success. I manually deleted all gnome-do files in home/.local/share/ and in home/.gconf/, but still after reinstalling Gnome-do just looks the same, has the same plugins activated. How can I completely wipe it off my disk? –  leonis_csem May 18 '11 at 18:00
add comment

I've found a solution for my problem: Due to the fact I was using Banshee 2.0.1 it wasn't possible for Gnome-do to communicate. Therefore I did the following:

  1. deinstalled Banshee 2.0.1 at first
  2. deleted all the Banshee files in my home directory
  3. uninstalled Gnome-do
  4. also deleted files in home, especially in .local/share/ and in .gconf/
  5. rebooted
  6. installed Banshee FIRST (important!!!)
  7. then installed Gnome-do

Now Gnome-do displays the Banshee-plugin correctly, so I do not need to install it manually.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.