Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In the middle of upgrade (from 13.04 to 13.10) the download stopped (for 2 hours, I was sure it was not going anywhere) and when even Firefox stopped working I was forced to reboot and, voila, my Satellite is blacked out. I tried "safe mode" and "repair damaged package" but no effect. (I can see these screens, in that sense it is not a total blackout and Satellite is TRYing to do something and give me lots of data but they dont make much sense to me) Could anyone suggest where I can go from here?

This is the 3rd consecutive upgrade fiasco for me upgrading, each time it gave me headache and it is affecting my view of Linux. Why does the upgrade have to be this "high risk" thing to do? Why cant I revert to the original state if I wasn't successful?

Anyway, any help much appreciated

share|improve this question
2  
It's hard to diagnose unless you give us some of that data. We need error messages. –  Oli Mar 17 at 15:53
    
[when I chose normal Ubuntu boot] libkmod error libkmod config c686 kmod config parse etc modprobe d options confi line 1 ignoring bad lines starting with options –  user145829 Mar 17 at 21:09
    
the above appears and automatically blacks out –  user145829 Mar 17 at 21:10
    
and when I chose one of the Recovery modes boot, many words and codes just flash by, too fast to read anything, and then the images of Nvidia logo flash as if this is a subliminal film and then black out automatically –  user145829 Mar 17 at 21:17
    
[and when I picked "Repair Broken Packages" and chose "YES" to the question "Do you wish to continue?" the following appears and Enter key leads to nowhere. the message is as follows] fsck from util-linux 2.20.1 dev/sda5:clean, 771020/9125888 files 6367492/36479744 blocks –  user145829 Mar 17 at 21:23

1 Answer 1

In the case of broken upgrades, booting to a Live CD or USB (doesn't really matter which version of Ubuntu) and using a terminal can sometimes rescue a borked upgrade. I have to underline that you may run into exactly the same issue as before but at this point, there's little to lose.

After booting to your Live-whatever, open a terminal and run

sudo fdisk -l
# work out which disk/partition is your main install and use it
#   instead of sda1 in the following:
sudo mount /dev/sda1 /mnt

for i in dev proc sys run; do sudo mount -B $i /mnt/$i; done
sudo chroot /mnt

At this point, for all intents and purposes you are root on your old system. Simply ask it to finish whatever package manoeuvres it was doing before it crashed:

dpkg --configure -a

And hopefully when that's finished you should be able to boot to it.

share|improve this answer
    
Thank u v.m. I couldn't understand ur saying "for i in dev proc sys run; do sudo mount -B $i /mnt/$i; done" So I skipped to "sudo chroot /mnt" and to "dpkg..." It started working on it smoothly but after a while, it stopped and said "halted because there are too many errors". When I rebooted and (after finding out normal boot is not working) opted for "recovery mode", I reached a normal screen and 13.10 seems to be installed. However, a lot is wrong and Im sure it's not complete. when I tried to re-do the above, now nothing happens. Where can I go from here? Shall I try to upgrade again? –  user145829 Mar 26 at 1:23
1  
Yeah, that won't work in a live setting unless you do the for..mount. But if you can get a root prompt through recovery mode, run sudo dpkg --configure -a and see what happens. –  Oli Mar 26 at 8:37
    
for i in dev proc sys run; do sudo mount -B $i /mnt/$i; done –  user145829 Mar 26 at 11:01
    
could u tell me how to understand the above? Or it does not matter as long as I have access to root through "chroot /mnt"? –  user145829 Mar 26 at 11:02
    
From a live environment it temporarily maps the running dev/proc/sys/run directories over the top of the static disk version... That means when you chroot into it, the chroot system has access to the actual system devices (which are invariably required at parts of a big system upgrade). Again, if you can get there from the recovery mode, you don't need this step (because you're already on the "real" system). –  Oli Mar 26 at 12:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.