Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I try to have a USB device recognized as being part of my user group. So I don't have to issue a sudo during development time when I debug my program which access those devices. Especially painful when using Netbean or Eclipse.

The udev rules never worked :

$ cat /etc/udev/rules.d/40-usbio.rules
SUBSYSTEM==”usb”, ENV{DEVTYPE}==”usb_device”, MODE=”0664”, GROUP=”odroid”,
ATTR{idVendor}==”04d8”, ATTR{idProduct}==”003f”

I also tried with mod MODE=”0666” and MODE=”0777”.

The weirdest part is that my USB camera has the same privileges and is part of the same group(root). But it never requires a sudo when I use cheese nor camorama.

ls -l /dev/bus/usb/001/013  ---------------> camera
crw-rw-r-- 1 root root 189, 12 Mar 16 21:25 /dev/bus/usb/001/013

ls -l /dev/bus/usb/002/007 ----------------> usb device
crw-rw-r-- 1 root root 189, 134 Mar 16 21:32 /dev/bus/usb/002/007

I also want to do the same with an arduino, but even with the proper rule file, it just does not work. Even after restarting udev or the computer.

How to fix this?

share|improve this question
I think you can accept my answer now ;) –  Sylvain Pineau Oct 16 '14 at 11:30
Welcome to Ask Ubuntu, You should accept Sylvain Pineau. See –  Sneetsher Feb 5 at 22:28

1 Answer 1

I'd add a NAME="my_device" in order to create the corresponding node.

And check your quotes, replace by ". It could be just that.

share|improve this answer
thx i cant believe i did not see the " problem it works :-) –  user254885 Mar 17 '14 at 15:38
Don't forget to vote/mark your question as answered please. –  Sylvain Pineau Mar 17 '14 at 16:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.