Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It really makes me ANGRY ! my wireless hardware is broadcom 4313 . ubuntu install it automatically but I can't use it . It says your hardware switch is off although it is on . after I use " rfkill unblock all " for several times it says your device isn't ready !! this is my rfkill list :

0: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
4: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

after I unblock all :

0: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
4: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

plz help me ! I use windows only for wireless !!!!

share|improve this question
    
After upgrading to Ubuntu 11.10 stopped working again. Any help will be highly appreciated. krasi@krasi-ideapad:~$ rfkill list 0: ideapad_wlan: Wireless LAN Soft blocked: no Hard blocked: no 1: ideapad_bluetooth: Bluetooth Soft blocked: no Hard blocked: no 2: hci0: Bluetooth Soft blocked: no Hard blocked: no –  Berov Oct 14 '11 at 20:51
    
I upgrade too but there is no problem !! maybe you should turn it on in windows and then restart and login to ubuntu ! –  mahdiar Oct 22 '11 at 5:46
add comment

3 Answers

up vote 0 down vote accepted

It realy works! /etc/modprobe.d/blacklist.conf add blacklist acer_wmi

to do this write sudo vi /etc/modprobe.d/blacklist.conf

then enter the password

go to a clean line and pres the insert key, this will enable input mode in vi

write

blacklist acer_wmi

then pres esc key several times.

then write :wq! then pres enter

(for sayfty back up the file first, once the acer_wmi is blacklisted reboot )

reboot

share|improve this answer
add comment

I'd rather comment but can't sorry!

which version of Ubuntu are you using? I encountered the same problem when I upgraded to Natty on my Lenovo Ideapad, also Broadcom 4313. You could try the solutions here: http://ubuntuforums.org/showthread.php?t=1700897

Ultimately I downgraded because nothing worked for me & everything is fine now. I'll wait for the next LTS. Hopefully you'll find a solution! I shifted my home to a separate partition so that I can do fresh installs without erasing my documents.

share|improve this answer
    
I use 11.04 and I used this method and I don't have any problem any more . –  mahdiar Jun 13 '11 at 19:27
add comment

For my Lenovo U160 I blacklisted the acer_wmi module and afterwards the wireless worked perfectly. Maybe that solves it for you as well.

in

/etc/modprobe.d/blacklist.conf

add

blacklist acer_wmi

share|improve this answer
    
thank you very much it works !!! –  mahdiar May 18 '11 at 16:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.