Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 14.04 on an Asus n550jv. I had this problem in 13.10 also.

I want to disable resume-from-suspend when the laptop lid is opened. The traditional answers to this involve echo "LID" > /proc/acpi/wakeup, but there is no entry for LID in this file:

$ cat /proc/acpi/wakeup
Device  S-state   Status   Sysfs node
RP01      S4    *disabled  pci:0000:00:1c.0
PXSX      S4    *disabled
PXSX      S4    *disabled
RP03      S4    *disabled  pci:0000:00:1c.2
PXSX      S4    *disabled  pci:0000:04:00.0
WLAN      S3    *disabled
RP04      S4    *disabled  pci:0000:00:1c.3
PXSX      S4    *disabled  pci:0000:05:00.0
GLAN      S4    *disabled
EHC1      S3    *enabled   pci:0000:00:1d.0
EHC2      S3    *enabled   pci:0000:00:1a.0
XHC   S3    *enabled   pci:0000:00:14.0
HDEF      S4    *disabled  pci:0000:00:1b.0
PEG0      S4    *disabled  pci:0000:00:01.0
PEGP      S4    *disabled  pci:0000:01:00.0
PEGA      S4    *disabled
PEG1      S4    *disabled
PEG2      S4    *disabled
SLPB      S4    *enabled 

acpi_listen isn't very helpful either:

$ acpi_listen 
button/lid LID 00000080 000000f5
video GFX0 00000080 00000000
button/lid LID 00000080 000000f6
video GFX0 00000080 00000000

I found some additional info, but sadly this does not help:

Toggle /sys/devices/platform/asus-nb-wmi/lid_resume using

# echo 0 > /sys/devices/platform/asus-nb-wmi/lid_resume

Refs:

https://github.com/torvalds/linux/commit/c0b91b6d5226247fa4fe894eb592bcc56bc7e9fd
https://wiki.ubuntu.com/Kernel/Reference/S3

share|improve this question
    
I actually want to enable resume when LID is opened :) But I also do not have LID listed in wakeup (sorry have to move to answer as this doesn't allow long paste) –  gliptak May 24 at 19:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.