Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I'm installing Pencil and get the following error: xulrunner: not found. XULRunner is a a requirement for Pencil. So how do I install XULRunner and it's dependencies?

share|improve this question

marked as duplicate by Braiam, Luis Alvarado Jul 24 at 17:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
For installing pencil see askubuntu.com/questions/68488/how-do-i-install-pencil –  lawal Sep 12 '12 at 1:45

5 Answers 5

up vote 11 down vote accepted

You can install the latest source of XULRuner by executing:

sudo add-apt-repository ppa:ubuntu-mozilla-daily/ppa
sudo apt-get update
sudo apt-get install xulrunner-2.0 xulrunner-2.0-dev xulrunner-2.0-gnome-support xulrunner-dev

Once installed you'll need to update-alternatives so it's used by default:

sudo update-alternatives --config xulrunner 

Be careful that this ppa also contains an updated version of firefox and thunderbird.

share|improve this answer
    
Ahh good I meant to install thunderbird when I got arround to it. and if FX breaks then I can fall back on chrome. –  Wes May 7 '11 at 21:45

You need to install one of the packages xulrunner-1.9.2 or xulrunner-2.0, depending on which version of xulrunner you need.

share|improve this answer
3  
On my Ubuntu 11.10, APT tells me, that the package is referenced, but not available?! Any ideas? –  alfonx Jan 10 '12 at 18:54

There's no longer a recent package available.

From https://developer.mozilla.org/en/docs/Getting_started_with_XULRunner

Put the following in a file and run it. It'll download a version that matches your current Firefox version, extract the files and create a symbolic link for convenience.

FIREFOX_VERSION=`grep -Po  "\d{2}\.\d+" /usr/lib/firefox/platform.ini`
ARCH=`uname -p`
XURL=https://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/$FIREFOX_VERSION/runtimes/xulrunner-$FIREFOX_VERSION.en-US.linux-$ARCH.tar.bz2
cd /opt
sudo sh -c "wget -O- $XURL | tar -xj"
sudo ln -s /opt/xulrunner/xulrunner /usr/bin/xulrunner
share|improve this answer

Though late but anyone that stubles here, you don't need to download XULRunner anymore. just download their deb from their site and you are good to go. Its working with Raring fine!

share|improve this answer

You can actually run xulrunner apps without installing xulrunner, and just using firefox.

If you look on https://developer.mozilla.org/en/docs/XULRunner, it says:

Firefox 3 and later ships with a private XULRunner package, which can run any compatible XULRunner application using the -app switch.

So I just untarred the pencil .tar.gz distribution, navigated into the user/share/pencil (or whatever) directory, and did:

firefox -app application.ini

tada! No additional installations needed.

share|improve this answer
1  
This just works, thanks! –  krlmlr Sep 15 at 20:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.