Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 13.10 on my Toshiba Satellite L645D-S4030 laptop and I am unable to detect any wifi networks, my wifi light is not on, but I can still use an Ethernet connection. I know that our wifi is working since we are using it on other devices. I already tried fn f8 and it does not turn on the wifi. I am new to Ubuntu and Linux and I am sorry if I am missing something obvious. How do I get my computer to connect to my wifi network?

Edit: http://pastebin.com/MgD4pzsZ Wireless-info.txt


EDITS FROM DISCUSSION BELOW

  1. sudo rfkill unblock all didn't work.
  2. lspci -v | grep -i wireless Doesn't return any results.

From @WildMan. It's a custom script written by him and friends that helps to diagnose wireless issues.

wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script

The results of the script can be found at http://pastebin.com/MgD4pzsZ as above.

@WildMan's response:

Your wifi is not showing up, it is an internal wifi correct? You may want to go into your bios and see if there is a setting to enable wifi if your bios is not UEFI then reset it and see if your wifi shows up. You can make sure it is plugged in good if none of those things help then your wifi card may be bad. Even if it was turned off or a driver was not installed you should be able to see if in the information you posted for me.

share|improve this question
    
Did you get a solution for this? –  Parto Mar 20 at 7:44
    
Yes, I bought a usb wireless adapter and now I have no issues with my wifi. I am guessing there was an issue with my wifi card, not ubuntu. I bought this one www.amazon.com/Panda-Ultra-aWireless-Adapter-150Mbps/dp/B00762YNMG/ref=sr_1_2?s=‌​electronics&ie=UTF8&qid=1395928359&sr=1-2&keywords=ubuntu+wireless+adapter and just plugged it in and I have had no issues since. –  user258943 Mar 27 at 13:54
    
Okay, that's nice. I wanted to start a bounty for your question. –  Parto Mar 27 at 13:59
add comment

2 Answers 2

Try running sudo rfkill unblock all in terminal and trying again to reconnect.

share|improve this answer
    
I ran "sudo rfkill unblock all" in the terminal, and nothing has changed.I can't see any of the available wifi connections, or any options even related to the wifi. I am wondering if maybe I need a driver for my wifi card? –  user258943 Mar 16 at 20:28
    
I need to know your wireless card model. Type lspci -v | grep -i wireless in the terminal and edit your question and include the result. –  Parto Mar 16 at 20:32
    
Sorry, but I just tried that and it didn't show anything. I just pasted it into the terminal and then pressed enter. Am I doing something wrong? –  user258943 Mar 16 at 21:06
    
It is safe to run it was written by me and some good friends it will help diagnose your wireless issue. Paste this command in a terminal wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script It will download a script and create a file named (wireless-info.txt, or wireless-info.txt.tar.gz) in your home folder paste the contents of the file here pastebin.com then paste the link back here. No internet then go to this link for running the script without internet. <ubuntuforums.org/showpost.php?p=12350385>; –  Wild Man Mar 16 at 21:18
    
What do you mean it didn't show anything? In my case, I got this output 02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01) –  Parto Mar 16 at 21:53
show 6 more comments

short answer:

sudo apt-get install linux-firmware-nonfree

explanation:

In lsmod you see the module "b43" gets loaded.

As you can see in modinfo this is a Broadcom chip and it requires firmware files. These are only available as BLOBs. That's why they are in a package with -nonfree in the name (in the "Multiverse" repository) and are not installed by default.

To find the package I simply picked one of the file names for the firmware and searched for package contents at Ubuntu Packages Search.

share|improve this answer
    
Post the output from dmesg | grep -e b43 -e Broadcom -e 43xx; to show what is now happening (after loading linux-firmware-nonfree and restarting laptop). –  david6 Mar 21 at 20:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.