Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had windows 8.1 in the SSD of my notebook with UEFI. I installed Ubuntu 13.10 in the HD.

After rebooting, the PC went directly to windows. I boot into the live cd of ubuntu and executed Boot-repair. Only that after that, i could't boot into anything that the system show the following error : "no such device : xxxxx-xxxxx-xxxxx-xxxxx , grub rescue".

But then, after changing setting on the BIOS, I found that after enabling and after rebooting desabling the secure mode I would see the grub working normally, showing both the OS's.

The only problem is after i reboot the system after selecting the OS in the GRUB screen, the error "no such device" is shown again, and for me to get into any OS again I need to Enable and Disable the secure mode on the bios .

Any suggestions ?

Sorry for my bad english. :)

share|improve this question
    
The symptoms are different, but the reply I just posted to this question is what I suggest for you, too. –  Rod Smith Mar 16 at 21:23
    
Hey Rod, thanks for your help, but I'd already tried your suggestion with rEFIND and it didin't work. But happily I solved my problem :). For whom may concern, all i did was change the "XHCI" space in my BIOS that was in AUTO to SMART AUTO. I have no idea of why did this worked, but I'm not complaining :P Solved, and if someone knows why did this worked, feel free to tell. –  joaaogui Mar 16 at 23:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.