Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since upgrading to Natty some programs using wine don't work.

  • Steam
  • Football Manager 2011

I've tried reinstalling and they both crash. I have tried Wine 1.3 and it still doesn't work.

I get the error:

http://paste.ubuntu.com/610185/

This is using wine version 1.2.

share|improve this question
2  
Unity and wine are unrelated. If the program is crashing on Wine, then it's likely that there are missing functions in a dll or something. –  RolandiXor May 17 '11 at 19:40
    
@Roland Taylor: Not really. They are related and may cause wine apps to crash in some cases. However, it's true, that crashing at start is unlikely to be caused by Unity. –  Rafał Cieślak May 17 '11 at 19:48
    
@raalcieslak: how are they related? Is Unity directly proportional to WINE (as a matter of speaking)? –  RolandiXor May 17 '11 at 20:39
    
What made me think that it was something to do with unity is that I used the applications on a beta version natty and it worked ok. But on the full version it no longer worked I assumed it was unity as it went through some pretty major changes. –  davbren May 17 '11 at 20:58
2  
If you suspect it is a problem with Unity, you can logout, login to Ubuntu Classic (i.e. Gnome 2), and try it. –  elmicha May 17 '11 at 21:58
show 3 more comments

4 Answers

Unity completely wrecks the Wine user experience in several important ways.

  1. Compiz (desktop effects) is required, and Compiz often messes with Wine
  2. The Application Lens does not show any subfolders or allow the user to filter by wine apps, making finding them in the big alphabetical mess of a list difficult.
  3. Most Wine apps show the Wine icon rather than their icon in the dock.

This happened because Unity was not designed with Wine users in mind. At all. This is partially my fault, as I was a bit busy this cycle and should have been shouting from the rooftops to get Wine users noticed, but I was a bit busy with personal life and barely managed to get the system tray not intentionally broken.

That said, your specific application issue is probably not Unity-related. I will be putting out a new Wine1.2 release soon and issuing a stable release update for Natty, however in the meantime I would encourage you to try Wine1.3 ("Beta release" in Software Center) or the Wine PPA.

share|improve this answer
    
Hi Scott, thanks for the information. Unfortunately I still have the same error with the 1.3 beta. –  davbren May 18 '11 at 18:26
    
Are you using proprietary 3d drivers? If not (and you used to) that could be the source of the issue. Also, the err: you see in the terminal might not be the source of the actual problem -- pasting a full terminal log on paste.ubuntu.com could be helpful. –  Scott Ritchie May 18 '11 at 23:37
    
I am using proprietary 3d drivers. Next week I'm going to do a full wipe and reinstall. I'll paste my terminal log in this evening. I'd really like this to get up and running. –  davbren May 19 '11 at 9:57
    
Ok Scott I have uploaded a full terminal log. paste.ubuntu.com/610185 –  davbren May 27 '11 at 15:47
add comment

It might be due to the newer version of Wine (1.2.2) in Natty Narwhal. In Maverick Meerkat came with Wine version 1.2. It has nothing to do with Unity.

share|improve this answer
2  
You can try Wine 1.3 from ubuntu-wine ppa: ppa:ubuntu-wine/ppa. Chances are it will solve your problem. –  Rafał Cieślak May 17 '11 at 19:49
    
@raalcieslak: this should be an answer. –  RolandiXor May 17 '11 at 20:39
    
to be honest I think the first thing I did was try 1.3 and still no dice. I might try and force 1.2 on there. See how it likes that. Cheers all. –  davbren May 17 '11 at 20:49
    
I get the error: 'err:d3d:IWineD3DDeviceImpl_Reset Cannot change the back buffer count yet' this is using wine version 1.2 –  davbren May 17 '11 at 21:41
add comment
up vote 2 down vote accepted

Ok I got it working.

If you get the error shown in the original post, find and save the listed .dll files to: ~/.wine/drive_c/windows/system32.

  • gameux.dll
  • import.dll
  • duser.dll
share|improve this answer
    
It's a little temperamental, after a few tries it seems to work though. It's good enough for the time being. –  davbren Jun 2 '11 at 9:37
add comment

Are you able to disable the 3D somehow?

http://appdb.winehq.org/objectManager.php?sClass=version&iId=21720

share|improve this answer
    
annoyingly, the 3D worked before. It just seemed strange that all of a sudden, it would stop working. –  davbren May 18 '11 at 9:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.