Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After not using the computer for a few hours, I return and see a black/blank screen. I see the mouse cursor. It responds to movements and it changes state as if the windows are there (changing to text or 'link thumb').

But all I see is a black screen. Anyone knows anything about this?

share|improve this question
I saw some threads regarding black screen when connecting an external monitor - this NOT the case here. – AlikElzin-kilaka May 17 '11 at 19:20
Also, I have a thinkpad edge 15, which was certified: – AlikElzin-kilaka May 17 '11 at 19:23
Perhaps it relates to the compiz memory leak problem that causes the windows not to be drawn? – AlikElzin-kilaka May 17 '11 at 19:24
Welcome to Ask Ubuntu, the way this site works is for you to continuously edit your original question with information, don't put it in the comments as they tend to get buried. – Jorge Castro May 17 '11 at 21:46
I experience this sometimes right after I boot my thinkpad. – king_julien Sep 6 '13 at 17:46

Have you tried restarting your window manager?

sudo /etc/init.d/gdm stop sudo /etc/init.d/gdm start

If that is the case, as you suggested in the comments it may be a memory leak or something with Compiz?

share|improve this answer
Everything is black, except fot the mouse curse. I don't know where to type what you suggested. – AlikElzin-kilaka May 19 '11 at 6:27
I did. It didn't work. And prefer service gdm restart to init.d – Elazar Leibovich Aug 11 '11 at 21:10

I had to disable the screensaver on my Thinkpad Edge 13 to solve a similar (same?) problem.

share|improve this answer

I think we nailed this one. You need to go to a tty shell (with no ui) by using, for example, ctrl+alt+F2. In the tty shell, you need to login and find any compiz process, using the command

ps -ef | grep compix

Then, kill all the compiz processes:

kill -9 <processes ids separated using space>

Then run unity to initialize the UI:


Give it a moment to load and go back to the 'UI shell', using ctrl+alt+F8, to see the UI being initialized.

share|improve this answer
Thanks Peter - your response gave me this idea. – AlikElzin-kilaka May 19 '11 at 12:06
up vote 0 down vote accepted

Another option (Can help a freeze - not just a black screen):

Go to a tty shell (with no ui) by using, for example, ctrl+alt+F2.

Just kill the compiz process (not compiz-decorator) - The UI will restart itself.

Identifying process id:

ps -ef | grep compix

Killing the process:

kill -9 <processes id>

Go back to the 'UI shell' (ctrl+alt+F7) - the UI will restart.

share|improve this answer

I occasionally have the same issue.

Try hitting Alt+F2 and then typing unity --replace.

share|improve this answer
Thanks. I will try it next time it happens. I read that using the --replace "acts the same as running unity without --replace" – AlikElzin-kilaka May 18 '11 at 8:05
Tried but didn't work. – AlikElzin-kilaka May 19 '11 at 6:28

On Ubuntu 13.04, the following may help when you have a black screen and a mouse pointer or some other indication/knowledge that you are running the lightdm desktop manager that ships with Unity.

Open up TTY1 by typing Ctrl+Alt+F1 (or F2 for TTY2, etc).

Log in, then enter:

sudo restart lightdm
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.