Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Ubuntu again after a few months of using Windows. At first I tried to install it by using an .ISO file, but I got stuck at 43% on the partitioner, so I figured out I should use the Wubi installer. So I installed Ubuntu 12.04, rebooted my PC, and went on to Ubuntu. Everything was working fine, except the internet connection. It was stuck trying to connect to Wired Ethernet, but it didn't work. When I changed from DHCP to manual and entered an IP-adress, it connected, but I still couldn't use internet, it wouldn't enter any sites. I've searched all over internet and tried different solutions, but none of them is working for me. I've had Ubuntu installed on the same computer before, and then it worked just fine, but not this time.

ifconfig output

eth0      Link encap:Ethernet  HWaddr c8:60:00:c4:4c:b4  
      inet6 addr: fe80::ca60:ff:fec4:4cb4/64 Scope:Link
      RX packets:3399 errors:0 dropped:0 overruns:0 frame:0
      TX packets:3090 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:2340549 (2.3 MB)  TX bytes:334975 (334.9 KB)
      Interrupt:20 Memory:f7300000-f7320000 

lo        Link encap:Local Loopback  
      inet addr:  Mask:
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:796 errors:0 dropped:0 overruns:0 frame:0
      TX packets:796 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:58956 (58.9 KB)  TX bytes:58956 (58.9 KB)

Network Manager Tool output

NetworkManager Tool

State: connecting

- Device: eth0  [Wired connection 1] -------------------------------------------
  Type:              Wired

  Driver:            e1000e

  State:             connecting (getting IP configuration)

  Default:           no

  HW Address:        C8:60:00:C4:4C:B4

  Carrier Detect:  yes

Speed:           100 Mb/s

Wired Properties

Carrier:         on

Route -n output

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

Ping output

connect: Network is unreachable

When I try to configure the /etc/network Interface file to set DHCP, my network tab says: device not managed. I have also tried to reinstall Ubuntu, but it still wont work. Help me!

share|improve this question

To get networkmanager to manage this interface, try this in a terminal

sudo nano /etc/NetworkManager/NetworkManager.conf

Change the line 'managed=false' to 'managed=true'

Save, then in the same terminal we need to restart the network manager.

sudo service network-manager restart

That should clear it up for you.

share|improve this answer
It didn't work.. Still trying to connect, but it won't – Steffen Aas Mar 16 '14 at 17:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.