Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to get Natty to play Quake Live with no luck.

Some notes

  • Installing in Chrome doesn't work at all -- it seems to download the XPI (firefox plugin file)

  • Installing in Firefox (latest -- at the moment this is 4.0.1) doesn't work due to incompatibility with v4.0.1.

  • Installing in older Firefox (v3.6.17) works, but I am still unable to play. Whenever quakelive.com is loaded, the browser is redirected to the install page (even when I have the plugin installed). This is the closest I have come to actually getting it working. Although, I'm not sure if this is a dead end. Many of the people on the Quake Live forums seem to use this solution.

Any help is appreciated.

Thanks.

share|improve this question
    
Scoobie - just to clarify - you've tried this from the forums? quakelive.com/forum/… –  fossfreedom May 17 '11 at 19:28
    
trying now.. not sure why my googling didn't turn this up.. if it works i'll update the answer –  Scoobie May 17 '11 at 21:51
    
the forum contained the needed fixes.. apparently "New users can't answer their own question for 8 hours..." fix goes like so. Download the XPI. Open with Archive Manager. Edit install.rdf and change maxVersion to '4.*' or whatever works. Add this line <em:unpack>true</em:unpack>. And install manually. Will post a real answer later. –  Scoobie May 17 '11 at 22:57
add comment

3 Answers 3

Fixing the problem is simple. This worked in Firefox 4.0.1 with Quake Live plugin version 1.0.433:

  1. Go to Quake Live and login (or sign up, then log in)
  2. The site will try to install the plugin
  3. Instead of allowing Firefox to install your plugin, right click on the link and save the file
  4. Open the file using Archive Manager and right click on install.rdp and 'Open With...' your choice of editor
  5. Modify the line containing <em:maxVersion>...</em:maxVersion> so that it reads <em:maxVersion>4.*</em:maxVersion> -- or substitute whatever version or versions you run
  6. Add a line containing <em:unpack>true</em:unpack> inside the <Description>...</Description> tag
  7. When you save, Archive Manager will ask if you'd like to update the archive. Click 'Update'
  8. Fire up Firefox and click Tools -> Add-Ons -> Extensions
  9. Click the button to the left of the Search text box (in the top right) and choose 'Install Add-on from File...'
  10. Select the XPI file which you just modified and install it
  11. Once finished, go to Quake Live and log in
  12. It should begin downloading all the game data you need to play
  13. Pick a game

Here is where I found the fix (thanks to @fossfreedom). In case something changes or you run another version of linux/firefox, you can always follow it to get a good answer or a link to a good one.

share|improve this answer
    
worked for me :) –  Patryk Oct 9 '11 at 22:26
add comment

Scoobie - (decided to convert my comment to an answer)

the suggested fix in the quakelive forum should work as described here

N.B. add the highlighted values into the XPI and change the min and max versions to 4.0 and 4.x to correspond with your Firefox version. Try changing the max-version to "9" - maybe that will stop the extension braking each time Firefox is updated.

share|improve this answer
add comment

Just unzip the QuakeLivePlugin_xxx.xpi file and copy the plugins folder to to ~./mozilla/plugins

You have to make hidden files inside your home directory visible (option from the explorer menu) Works fine with FF5 under Linux.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.