Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got Ubuntu 13.10 installed on my laptop's physical drive. System can be booted as a standalone OS through NeoGrub. It's also attached to a VirtualBox machine in Windows host using a raw VMDK file. It worked perfectly until recently.

I haven't started the VM for a while, but I've been using Ubuntu on bare metal. Today I have started the VM and it booted correctly, but Unity panel and launcher were invisible. Panel's shadow is visible, though, and both panel and launcher are clickable. Here's a screenshot with the menu opened by clicking where the appropriate icon should be:

Screenshot of desktop with Power menu open and Unity windows invisible

  • I haven't changed any Unity settings recently.
  • The OS was installed on a clean partition, not upgraded from previous versions.
  • Everything is up to date.
  • VirtualBox Additions are installed.
  • I've got dedicated NVIDIA GPU, but Nouveau is blacklisted and Ubuntu is using Intel's integrated GPU when running on bare metal. No NVIDIA drivers are installed. This setup worked before.
  • All required partitions (/, /home and swap) are attached to the VM. Raw VMDKs present real partition layout to guests, so it's probably not a culprit. /home is accessible and free -m shows that swap is available.
  • All other windows show up correctly.
  • OpenGL and Unity are enabled in CCSM. Re-enabling Unity doesn't fix the problem. (suggested here)
  • Removing ~/.compiz and ~/.config/compiz-0 followed by sudo service lightdm restart didn't work too.
  • The file ~/.drirc mentioned here doesn't exist.
  • The problem appears only in the VM. Everything is fine when running on bare metal.
  • Disabling accelerated 3D in VM settings helps, but performance is terrible. I consider it a workaround, not a solution.

I recall this happened before when I was trying to run Ubuntu in a pure VM (with a virtualized hard disk image) after installing VBox Addons. It started to work later, thanks to some update I guess.

Can this problem be fixed without waiting for patches to appear?

share|improve this question
    
Strange, I suppose this also survives a reboot of the VM? –  terdon Mar 15 at 19:54
    
Yes. And the shutdown dialog (the one asking whether I want to reboot or power off) is invisible but clickable too. –  gronostaj Mar 15 at 19:58
    
I had the same problem. Try to reinstall the guest additions. worked for me. –  user259484 Mar 18 at 11:32
    
@stadtler no change. Disabling accelerated 3D in VM settings helps, but performance is awful, so I'm still looking for real solution, not a workaround. –  gronostaj Mar 18 at 12:39

1 Answer 1

up vote 1 down vote accepted

OK, this time I have an answer, at least for my Virtualbox installation:- The problem was with the version of "VirtualBox Guest Additions". I was running version 4.2.12. After updating my VB installation I then fired up my guest and pressed HOST+D (HOST in my case is the right CTRL key) This popped up a message asking if it was ok to install the Guest Additions. After OK'ing this the old version was replaced. On restarting the guest now displays the Panel and Launcher correctly

share|improve this answer
    
It worked, thank you. Just a note: if you have older version installed from a repo, you may have to remove it before installing from VirtualBox. –  gronostaj Mar 20 at 21:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.