Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

my ubuntu is showing me this error:

abhishek@abhishek-ThinkPad-R61:~$ youtube-dl -f worst http://www.youtube.com/watch?v=QGhx-u-c5Cg
[youtube] Setting language
WARNING: unable to set language: nonnumeric port: 'port_no'
[youtube] QGhx-u-c5Cg: Downloading video webpage
ERROR: unable to download video webpage: nonnumeric port: 'port_no'
abhishek@abhishek-ThinkPad-R61:~$ 
share|improve this question
    
you could update the utility with sudo youtube-dl -U and then check if that fixed the problem.. –  rusty Mar 16 at 8:47

1 Answer 1

Try adding as a service in Konqueror browser the youtube-dl addon. You can find it in Konqueror - Settings - Configure Konqueror - Services, and once you get here press the Download New Services button, and look for youtube-dl or video-dl package and install it.

share|improve this answer
    
How does this answer the question? How do you know OP is using Kubuntu or KDE or Konqueror? –  DK Bose Mar 15 at 16:21
    
I use Konqueror in Xubuntu right now, no big deal, and also installed it in Lubuntu in the past. It is true that Konqueror browser comes with a bunch of other packages but it works fine, and it is a fast and decent browser for any Ubuntu based distro. –  Taz D. Mar 15 at 17:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.