Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm used to the Windows Korean IME... the Ubuntu Korean IME seems to randomly switch to Korean mode, and I have no idea how to switch back~ Please explain:

  • How to completely uninstall/disable Korean input

  • How to identify which IME I'm using; I know there are various Linux IME's. I knew about Nabi, and tried installing that one, but it seemed like part of the install failed. IBus seems to come pre-installed on Ubuntu. Originally,IBus only offered Chinese IME, but Korean appeared after the failed Nabi installation.

  • How to tell which input mode the IME is currently in (Korean Hangul or English 'Roman').: Ibus adds a tiny keyboard icon to the top panel, but it doesn't seem to display the current input mode anywhere. (Compare to Windows Microsoft IME, which displays an icon depending on the input mode (the letter 'A', or the Korean equivalent '아').
  • How to switch between Korean Hangul mode and English 'Roman' mode: The IME seems to randomly switch to Korean mode when I type rapidly, but I'm sure I am triggering something.


  • The questions above are most critical, but while I'm at it... How to convert Korean characters to their Chinese equivalents (the Hanja key).


share|improve this question

1 Answer 1

up vote 2 down vote accepted

OK, I started to figure it out. Part of it was related to installation issues. Mainly, a logout is required before the IME is functional!

How to completely uninstall/disable Korean input: I uninstalled Nabi the same way I installed it: via Ubuntu Software Center. Languages can be enabled/disabled via "System Settings" > "Language Support".

How to identify which IME I'm using: I uninstalled Nabi, so now I'm pretty sure IBus is the IME being used.

How to tell which input mode the IME is currently in (Korean Hangul or English 'Roman'): The IME does overlay a status panel above other windows. However, it won't be enabled/visible until after a logout. The IBus keyboard icon in the panel also changes to a Korean-design icon when in Korean Hangul input mode.

How to switch between Korean Hangul mode and English 'Roman' mode: The keyboard shortcuts are configurable from IBus preferences. By default, Ctrl - Space. The keyboard short-cuts do not work until after a logout has been made.

... and I guess the random switching to Korean mode was a bug because the IME was in a weird state before logout.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.