Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have defined a custom keyboard layout following this description: Custom keyboard layout definitions

The layout definition is added to this file: /usr/share/X11/xkb/symbols/us and it starts like this:

partial alphanumeric_keys modifier_keys
xkb_symbols "usintde" {

  name[Group1]= "English (US, alternative international and German)";
  include "us"

I can use it on the command line using setxkbmap 'us(usintde)'. However, in Ubuntu 13.10, I can not choose it from the Unity settings menus. I tried settings > text input and then clicked on the + sign, but none of the layouts is named like mine (also after new login and restart).

How can I activate this customly defined layout (and then use it in the layout switcher)?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Reading a similar question (Adding custom keyboard layout to Xubuntu 13.10), this page showed me the answer: I have to edit the evdev.xml and base.xml files in /usr/share/X11/xkb/rules, adding a variant snippet, too.

This is nicely described there. Just one more caveat: Use setxkbmap '<file>(<yourvariant>)' (for the example in the question: setxkbmap 'us(usintde)') to test your layout and to make sure that you can log in again.

Sorry for this duplicate. I read many similarly named questions and answers which only treated the symbols/xy files and old versions of the unity settings. I found this one too late.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.