Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop - DELL Studio 1773, but I'm pretty sure the model does not matter. One of it's features I love most is the fact it has TWO headphone outputs. This means Ubuntu can use them to output 4.0 sound.

But 4.0 is not enough for me. I would like to get 5.1 surround output.

At first sight it seemed impossible for me, but it turned out it is technically possible. The laptop has two audio outputs and one audio input. If the input could somehow output sound, I would get 5.1 surround sound, right?

The laptop had Windows Vista preinstalled. And it had a preinstalled app for tuning my sound's parameters (volume, basic filters etc.). I found out this app is able to output 5.1 sound, using the Line In as output (to be precise: it used it for center/sub channels)!

That leads to conclusion it IS somehow possible to get the Line In to work as output. How can I do this in Ubuntu?

As the preinstalled application proved, the soundcard is capable of outputting audio through what seemed to be an input inlet. But in Ubuntu it behaves only as input.

-

Now, my question is:

Is there any way I can change this, and force my system to do similar trick and output 5.1 audio using 2 headphone outlets, and 1 audio input inlet?

share|improve this question
    
This can be done in software. I am not familiar with the terminology so I cannot get out a page from Google. You can ask at www.alsa-project.org or look at the website, as this is an Alsa issue. –  user4124 May 17 '11 at 15:07

1 Answer 1

If you are lucky, you simply open 'alsamixer' in a console.

Hardware 'channels' have volume bars; switches do not. Use the 'm' letter to change settings. Maybe you have a switch to change that input/output behaviour. Use F-keys and left/right arrows to see all your options.

Now having pulseaudio as default in Ubuntu, all these alsa settings are somehow 'hidden'. Following picture shows Alsamixer with some 'F2' option.

Alsamixer with some 'F2' option

2nd chance

If that is not working, you may have the chance to be able to choose some options for your card and set them as system default on boot.

For that you will have to modify /etc/modprobe.d/alsa-base.conf (documentation: http://www.alsa-project.org/main/index.php/Matrix:Module-ca0106 )

To choose an option, add something like this to your /etc/modprobe.d/alsa-base.conf...

    # ALSA portion
    alias char-major-116 snd
    alias snd-card-0 snd-ca0106   
    # module options should go here
    options snd-ca0106 foo=bar

I am not a 100% sure about that module ca0106 though... You can verify that with 'lspci | grep audio' and 'lsmod' in a console.

share|improve this answer
    
Neither of these work for me :( –  Rafał Cieślak Aug 19 '11 at 11:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.