Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Presently Installed Ubuntu 12.04 LTS as stand alone through USB overwriting older linux versions option. Previously installed as dual with Windows XP. Then for about 7 times as stand alone with custom partitions. Used all space for partitions. Missing swap problem occurred. Once Nvidia driver update showed up. When updated screen went reso wrong. So I always avoid nvidia driver update. Lastly allowed a lot of free space to avoid bad sectors and installation successful. This time the missing swap area problem is not arising.


But always when boot for first time, Both mouse and keyboard inactive in Login screen. I have to switch off directly and reboot.

Always for the second time - Ubuntu leads to GNU GRUB recovery option screen. When I choose (recovery option) everything properly recovers to a working Login screen with activated mouse and keyboard.

I am very new to Linux and Ubuntu, but can follow instructions both terminal and desktop based. I am planning for a big UBUNTU awareness program in my area and need help to make myself professional. Please do Help.

share|improve this question
Do not "switch off directly". Try sudo shutdown -h now, or shutdown from your UI. – Elliott Frisch Mar 14 '14 at 4:19
Since mouse and Keyboard deactivated, direct switch off is only way. Cant access TERMINAL. Always for second time it goes to recovery screen and on recovery option, things go correct. – Partheeban Mar 14 '14 at 4:20
Can you ssh to the machine? Unplug the mouse and keyboard, and then plug them back in. – Elliott Frisch Mar 14 '14 at 4:20
First Thanks Elliot for quick help. What is "ssh". sorry for the ignorance of mine in some basic areas. Will try RePlugging the input devices. Will be Back soon. – Partheeban Mar 14 '14 at 4:24
Tested inputs RePlugging, but not working. But I think I found one common occurance. Every alternate boot, when I directly shutdown due to deactivation of input devices, I was taken to recovery screen and successful boot. But next time same error occurs. So Ubuntu can only boot through recovery mode. Some error has to be corrected there. – Partheeban Mar 14 '14 at 4:39

I had a similar problem once, and what I noticed in my case was that it was user-dependant. so I simply created a new user for the staff, and used that to log in, and it was fine with the new user. I then deleted the offending user account. from your information it is a bit hard to tell what is going on, but if you show some log files we can have some better ideas, /var/log/syslog, /var/log/dmesg, and /var/log/auth.log would be a good start.

share|improve this answer
Thanks snap for the support. My problem is close to this following link :…. Following this area. But I need users and hence will try that next. Thanks a lot – Partheeban Mar 15 '14 at 12:44
up vote 0 down vote accepted

I overlooked the Hard Disk Bad Sectors When I do Custom Partition. So the swap cannot mount properly. So I found out size of my hard disk Badsectors. Then I minus them from my total hard disk space and minus again with some extra space and then made the custom partition. Now the problem solved and Ubuntu began to load excellently.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.