Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an iMac G5 that I'm looking to install Ubuntu, Kubuntu, etc, and release of Ubuntu on to. Whenever I try to install any version (I've only tried 12.04 and above), I install the OS without errors, but when I restart after installation, I get an error that told me to go to Again, this works with every Ubuntu release I've tried on this specific computer.

I have, although, successfully installed Ubuntu 12.04 on a Mac mini G4, which works entirely fine, which is confusing, because I had no need to install firmware on that, yet I have to install seemingly new firmware on a computer that is older.

This iMac runs on a PPC processor, so it's probably no longer supported.

By the way, I'm completely and totally new to Ubuntu, and I probably have no idea what I'm doing. I needed to switch to something other than OS X because neither of my 2 semi-old macs seem to co-operate with OS X very well. My Mac mini is fine, but this iMac G5 will not stop giving me issues.

I'd really appericate any help that anyone out there might have.

Thanks in advance.

share|improve this question
The exact fix is pretty easy but depends on your Ubuntu version. Please edit your question to tell us which version you have or will install. – chili555 Mar 14 '14 at 1:10
12.04 is the version – user258048 Mar 14 '14 at 1:27

The firmware referred to is proprietary firmware for the specific wireless device in the machine. With a temporary wired ethernet connection, it can be installed with:

sudo apt-get install firmware-b43-installer

Reboot and the message will be gone and the wireless present.

share|improve this answer
I don't think I'm doing this at the right time/place. I'm doing it once yaboot starts up, which is probably wrong because if I remember correctly it said something about an invalid directory. I just need to know when/where to do this command. – user258048 Mar 14 '14 at 2:29
Please do the command when the computer is fully booted up to the desktop. If this firmware message appears during the boot process,ignore it until you are fully at the desktop. It may take a few moments; be patient. – chili555 Mar 14 '14 at 12:04
I tried waiting for 30 minutes or so. The computer just freezes at the error and refuses to boot any further – user258048 Mar 14 '14 at 13:34
That sounds like this problem and I suggest the same solution.… – chili555 Mar 14 '14 at 14:26
The thing is... even to do the first step, my keyboard doesn't have an Insert key because this is on a mac. The Esc key doesn't work either. – user258048 Mar 14 '14 at 14:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.