Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am very used to alt-drag for moving and resizing windows.

However, I can't get it to work in xubuntu 13.10. (I just recently installed it in a virtual box machine). If I change it to a different key (shift for example), shift-drag works as expected. When it is set up to use alt, and I press the alt key, it activates the menu shortcuts, but doesn't drag or resize windows if I click.

EDIT:

Yes, that sounds like exactly the setting I need to change. However, when I pull up the keyboard settings, that tab isn't there. I'm using xubuntu 13.10.

screenshot of keyboard settings

So where else might that setting live?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Found the problem:

I am running inside a virtual box, and had Alt-dragging turned on in the host system. Even though Alt-drag didn't drag the whole VB window, it disabled it in the guest OS. If I turned it off in the host, it works as expected in the guest.

share|improve this answer

Open the System Settings application, then go to Keyboard -> Shortcuts -> Launchers. You can disable the "Key to show the HUD" which seems to prevent you to use the alt-drag:

enter image description here

share|improve this answer
    
And how do you activate Alt click for moving/resizing? Disabling the HUD key did not activate it, presumably it has to be activated somewhere else. –  terdon Mar 13 at 23:19
    
@terdon To activate the Alt click: Settings -> Windows Maganer Tweaks -> Accessibility. –  David Oneill Mar 14 at 16:05
    
@DavidOneill thanks but I don't have that on my 13.10. No Window Manager Tweaks and no Accessibility either. Do I need to install something? –  terdon Mar 14 at 16:11
    
@terdon are you using xubuntu 13.10? Not straight ubuntu. –  David Oneill Mar 14 at 16:18
    
apps.ubuntu.com/cat/applications/saucy/xfce4-settings is what you're looking for I think –  Sylvain Pineau Mar 14 at 16:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.