Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Original Question:

After I replaced my Ubuntu 10.10 with 11.04 all I get when I Ctrl+Alt+F1–F6 into a tty is a black screen. Also when I boot there's a while of black screen after grub2 menu is displayed. Then until just before gnome starts it stays black.

I have an Nvida Geforce Quadro FX 770M on my HP EliteBook 8530w. How do I get my ttys (aka 'virtual terminals') to work again?

My efforts in chronological order:

  • So grub and gfx-payload seems to be the problem, I figured. I went along with this guide for higher tty resolution. Which led to the grub2 menu displaying in my native resolution rather than 800x600. The black screen problem remains.

  • I googlehit some bugreports on other nvidia cards having that problem.

  • I tried uninstalling the nvidia driver. No effect. Also tried different resolutions

  • With an older version of the kernel it works. Though not perfectly. The ttys are usable, black screen between grub2 menu and gnome start remains. Not really a solution.

  • Tried so much, that I lost track. Reinstalled grub2 and linux-image-2.6.38-8-generic. Then did this to my /etc/default/grub in accordance with the aforementioned guide (/etc/grub.d/00_header edited as well):

    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    #GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=3
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    #GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    GRUB_GFXMODE=1680x1050x32
    

    To my surprise I can now use my ttys in native resolution. Black screen between grub2 menu and gnome login screen is still there though. That is annoying since I also use an encrypted disk thus having to enter my passphrase in total dark... Still looking for a solution but urgency is low.

  • Downloaded and installed a later version of nvidia driver. No difference to last edit.

  • Tried GRUB_CMDLINE_LINUX="vga="-parameter. No effect.

  • nomodeset has no effect. not even in combination with vga=...

  • Tried echo FRAMEBUFFER=y > /etc/initramfs-tools/conf.d/splash no effect (see comment)

  • On the verge of resignation...

  • Bounty period soon to end.

share|improve this question

closed as too localized by con-f-use, Jorge Castro, Ringtail, Thomas W., Javier Rivera Nov 8 '12 at 17:27

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Did you try "nomodeset" on the "quiet splash" line to disable kernel modesetting? –  maco May 18 '11 at 21:29
    
tried it allready in another configuration. now I tried it again. Still no worky worky ;) Thanks anyways. –  con-f-use May 19 '11 at 9:43
2  
Con-f-use - I'm still confused :-) with the question - the TTYs you can still use natively but you have a black screen plymouth? Have you tried the framebuffer=y trick? ubuntuforums.org/showpost.php?p=9175901&postcount=4 –  fossfreedom May 19 '11 at 21:26
    
at frist both, ttys and plymouth were black. now i got the ttys to work and only the password query for my encrypted drives (that comes up right after grub2-menu) is black –  con-f-use May 20 '11 at 1:13
    
As per guidelines (askubuntu.com/help/reopen-questions) this is a "Please reopen" request. I don't believe this is too localized -- it happens on all my machines with nVidia proprietary installed. "Unlikely to help future visitors" is incorrect: I am a future visitor, and I'm certainly hoping the answers will help me fix this exact problem. I don't think the question needs to be edited or reworded, it perfectly describes the issues I have. –  Ash Apr 2 at 22:25
add comment

6 Answers 6

I experienced the same problem as you when I replaced Ubuntu 10.10 by a fresh install of Ubuntu 11.04 (and later on, Ubuntu 11.10): my "console" tty's were desperately blanks but actually working -- i.e. I could log in and enter commands that actually work, but there was nothing visible on my screen.

I spent a huge number of hours on Google and various Ubuntu forums, I tried plenty of suggestions and I finally came to the following conclusion: the problem is linked to the proprietary NVIDIA driver -- if I remove the proprietary NVIDIA driver and use the "nouveau" driver, the problem disappears but then of course I can't benefit from the hardware acceleration any more.

I managed to fix the problem on my system (ZOTAC ZBOX with on-board NVIDIA GT218) by using the Uvesafb framebuffer driver.

Here is the procedure I used:

apt-get install v86d
apt-get install hwinfo
hwinfo --framebuffer

From hwinfo's output, I picked up the "best" resolution compatible with my screen -- in my case 1280x800 24-bit -- and I added the following line at the end of /etc/initramfs-tools/modules file:

uvesafb mode_option=1280x800-24 mtrr=3 scroll=ywrap

(The string "1280x800-24" comes from the resolution I chose -- your mileage may vary.)

Then I rebuilt grub and initramfs images as follows:

update-initramfs -u
update-grub

Finally I rebooted the system and my console tty's were finally visible again.

I don't use encrypted filesystem, so I cannot check whether or not the passphrase is to be entered "in the dark", but anyway I hope the above workaround will help you.

share|improve this answer
    
This worked great for me! –  Radu Rădeanu Apr 19 '13 at 8:39
add comment

Similar problem

I found out that it had to do with the VGA on my motherboard which I wasn't using. When I connected a monitor to the mobo VGA and hit CTRL-ALT-F1 the tty displayed on that monitor instead.

Went to BIOS- set the vga to enable when there is no graphics card - everything's fine now.

Pity I reinstalled and formated everything before I got to this stage :(

share|improve this answer
add comment

I encountered the same problem, all ttyX terminals running (getty proccesses running), but no loggin prompt on either Ctrl+Alt+F1-6 (black screen with rest of splash picture on top). When I type in logname and password user is properly logged (who command). Only solution I found is to switch to text mode while boot proceeds.

1) edit: /etc/default/grub GRUB_GFXPAYLOAD_LINUX=text

2) and update of grub: update-grub2 update-initramfs -u

share|improve this answer
    
Been working on this all day. Your downvoted answer was the only fix thus far. –  Chris K Jan 12 at 1:00
add comment

If you are using proprietary drivers this is the fix
http://www.omgubuntu.co.uk/2011/05/how-to-fix-the-plymouth-boot-screen-when-using-proprietary-graphics-drivers/

share|improve this answer
    
First of all, that script is really bad work. It doesn't create backups. It will replace flasely, if lines are commented out. It suggests wrong resolutions bits and wrong resolutions if you're using dual screens. Also it could be changed installing maleware anytime. Luckily I looked in the code before invoking it. –  con-f-use May 20 '11 at 0:34
    
Now to the actual issue: The changes suggested in the script didn't help much - if at all. I can see part of the pre-gnome loading screen now but not the password qurey for decrypting my disks. Also said loading screen fills only a tiny part on the top left of my screen. But I suppose this is only due to the changes I made beforehand and the fact, that I reactivated "quiet splash" in order to test the fixscript. Half of the options it sets are outdated anyways. –  con-f-use May 20 '11 at 0:38
add comment

Mine fades to black slowly, like some kind of security feature, If I login, and I gotta type my login name perfectly, press enter, then enter my password, enter. I can see stuff just fine. Maybe your screen is fading to black very quickly.

Try loging in. I don't think this is related to a graphics card, since I have had this with 11.04 and 11.10, and maybe the version before. On two cards, NVIDIA and ATI. (with fancy-super-secret-non-open source drivers)

share|improve this answer
add comment

I started experiencing this problem after making the required changes for wireless to connect even before user login to the desktop environment .

I followed the instructions provided at this page for achieving the same.

After these changes my sessions were not at the correct runlevel. I was able to get the tty console back by reverting the changes made in /etc/init/rc-sysinit.conf.

Now my tty consoles are working fine and the issue was not related to grub or display drivers.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.