Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Right now, I have Ubuntu 13.04, and using sudo-apt-get dist-upgrade does not get me the 13.10 update.

Whenever I sudo-apt-update or upgrade lately, I get:

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

It has been for a couple of months (I'm not actually sure, but it has been a long time), and I want to fix this somehow.

Edit: from sudo cat /etc/apt/sources.list

Edit 2: from sudo vim /etc/apt/sources.list to comment out the last two lines

Edit 3: I found out the problem on my own.

# deb cdrom:[Ubuntu 12.10 _Quantal Quetzal_ - Release amd64 (20121017.5)]/ quantal main restricted

# See for how to upgrade to
# newer versions of the distribution.
deb raring main multiverse restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb raring-updates main multiverse restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb raring universe
deb raring-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb raring-backports main universe multiverse restricted

deb raring-security main multiverse restricted
deb raring-security universe

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb raring partner
# deb-src quantal partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb raring main
deb-src raring main
## deb debs all
## deb karmic main
share|improve this question
Please post the contents of your /etc/apt/sources.list. – terdon Mar 13 '14 at 18:39
If it says permission denied you are not the administrator. Open a terminal (Ctrl+Alt+T) and run sudo cat /etc/apt/sources.list. – terdon Mar 13 '14 at 22:24
Because that's not how Linux works, you have set up a normal user, who has the right to become the administrator by using sudo. It's a very different paradigm than Windows. – terdon Mar 14 '14 at 2:23
The last 2 lines should be removed or commented out. – Danatela Mar 14 '14 at 2:30
And so am I which is why I only posted a comment about the "being administrator" part :) The "admin" username on Linux is root by the way. – terdon Mar 14 '14 at 2:30

4 Answers 4

apt-get dist-upgrade does not perform a distribution upgrade to the next release as it sounds. From the man page :

dist-upgrade in addition to performing the function of upgrade,also intelligently handles changing dependencies with new versions of packages; apt-get has a "smart" conflict resolution >system, and it will attempt to upgrade the most important packages at the expense of less >important ones if necessary.

If you want to upgrade to the next available release of Ubuntu, you can do this by using the do-release-upgrade at the command line. This command will automatically generate the required /etc/apt/sources.list file for the next release.

share|improve this answer
For some reason, /etc/apt/sources.list is saying, "Permission Denied." – Flair Mar 13 '14 at 20:44
And, for do-release-upgrade, it says, "Could not calculate the upgrade". – Flair Mar 14 '14 at 3:20
"Could not calculate the upgrade" may be a result of using external sources of packages you may have added. In your sources.list attached with your original question, I see that the two last lines are external sources, comment these two lines and see if the command can run. – Benoit Mar 14 '14 at 8:11
Don't forget to use sudo when you are manipulating the sources.list file, this should remove the "Permission Denied" errors. – Benoit Mar 14 '14 at 8:12
I commented the last two lines out, but it still "Could not calculate the upgrade". – Flair Mar 14 '14 at 23:44

Contrary to what it seems, sudo apt-get dist-upgrade does not upgrade to the new version if you do not changes the sources before.

The correct command is sudo update-manager or sudo update-manager -d.

More info in

share|improve this answer
I face two problems. 1. It tells me I am upgrading to a beta release even though I am certain that 13.10 is finally stable. 2. It then tells me to stop installation, for the manager cannot calculate the software upgrade. – Flair Mar 13 '14 at 21:11
Try without the -d... – Rmano Mar 13 '14 at 21:15
That solved one of my problems. Yet, the manager still tells me that it still "cannot calculate the upgrade". – Flair Mar 13 '14 at 21:19

Open the software and updates application and tab to updates. Ensure you have option 'Notify me of a new ubuntu version' set to 'For any new version'. It may be that you have updates set to only download LTS versions, which is the default option.

share|improve this answer
The LTS has never been on default for me. I think LTS updates are default if I download a LTS version. – Flair Mar 13 '14 at 20:39
up vote 0 down vote accepted

I have found the answer to my question. I ran the command of sudo apt-get remove xserver-xorg-video-* which means that there are other third-party software I did not remove for the upgrade of 13.04 to 13.10.


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.