Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I set up a manually provisioned environment successfully (in local network among x3 12.04 ubuntu servers.) However adding the second machine failed twice. After the third try (installed missing dependency) their remained x2 'pending' machines.

I tried destroy-machines on those, than used destroy-environment to try and start over. Now when I add machine I get:

ERROR machine is already provisioned.

I have tried uninstalling/re-installing along with removing all juju files in ~/.juju.

Any ideas on how to start over or remove the provisioning?

Thanks!

share|improve this question

1 Answer 1

Per documentation on https://juju.ubuntu.com/docs/config-manual.html:

Note: If you have an existing configuration, you can use juju generate-config --show to output the new config file, then copy and paste relevant areas in a text editor etc.

On each failing node: rm -rf /etc/init/juju*

also: rm -rf /var/lib/juju

This will allow a normal add-machine

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.