Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been using Ubuntu 13.10 for months now without too many hassles. But a couple of days back, my system offered to install this major update and of the many things that have gone wrong, the most prominent one is I am unable to change the brightness of my laptop (Dell Inspiron 15R) using my brightness hotkeys and as far as my knowledge goes, you can't do this graphically using Ubuntu's settings (please correct me if I am mistaken).

How can I rectify this? Please help my poor eyes!

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Are you running nvidia drivers per chance? This seems to be a common issue. Try installing the xbacklight package as a workaround. It won't fix your function keys but at least you can look for an answer without melting your retina's.

$ Sudo apt-get install xbacklight

You can then adjust the settings from a terminal using commands found here.

To increase brightness by 20%:

$ sudo xbacklight -inc 20

Alternatively to decrease:

$ sudo xbacklight -dec 20

Or use the -set parameter to define the exact level:

$ sudo xbacklight -set 50

If this works for you may want to add a new startup entry so it runs on boot. Open "Startup Applications" and add the following details:

Name: Brightness

Command: xbacklight -set 60

Click add and you are done! Hope this helps.

share|improve this answer
    
It worked! You saved my eyes, thanks a ton! and no, I running AMD drivers... –  Darth Coder Mar 13 at 17:06
    
No problem. The reason I said nvidia is because I am having to use this same workaround at the moment. The nouveau driver works perfectly with my function keys and backlight, but there is still work to be done with propriety drivers in 13.10+. –  bleeves Mar 13 at 17:11

I have Dell Inspiron 15 and in a fresh ubuntu installation I always do the following to fix the brightness

Edit the grub configuration file by running in terminal : 
gksu gedit /etc/default/grub

Change this line:
GRUB_CMDLINE_LINUX=""
To:
GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\""

Save the file And Update Grub:
sudo update-grub

Reboot and test.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.