Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There are some problems using Firefox in Kubuntu.

  • The menus are ugly and do not use the KDE style.
  • The file browser for uploading or opening files is also ugly, and is not the default KDE mini-file-browser.
  • The filetype icons are not shown correctly in the Downloads window.
  • In the small Downloads window, if I right-click a file and select "Open Containing Folder", nothing happens.

gtk3-engines-oxygen is installed and "oxygen-gtk" is the default GTK style in System Settings > Application Appearance > GTK.

Here's an example of what it looks like:

enter image description here Something tells me I am missing something to integrate Firefox into KDE. What can I do to get Flamewolf - ahem Firefox to integrate nicely with KDE?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

I would add the Blue System's PPA for Firefox integration, as recommended straight from MMartin Gräßlin, KWin's main developer. Link: Firefox KDE integration in Debian Testing

The Launchpad PPA page for Blue Shell's Firefox can be found here: firefox-kde

Note that two packages need to be installed: firefox, and firefox-kde-suport

This will lead to a better experience, as shown in the picture from Martin's blog post. The reason this is not installed by default in Kubuntu is that Kubuntu tries to maintain a "pure" KDE experience, and therefore rarely alters upstream packages. And since Firefox is not a KDE application, upstream (KDE) would have no interest in supporting Firefox. This is the best answer for how to handle integration with Firefox + KDE in Kubuntu.

Editorial: If more people file bugs on the matter, maybe it can be addressed. Esp. since Firefox is the default browser now for Kubuntu 14.04, which is a LTS.

share|improve this answer
    
Yes, this is largely a bug in Firefox , as Mr. Gräßlin points out. Thank you. –  Richard Mar 14 at 18:41
add comment

The first thing when you install KDE Distro is to install gtk3-engines-oxygen.

sudo apt-get install gtk3-engines-oxygen

Then re-apply gtk settings in System Settings/Application Appearance/GTK

re-select a GTK2 Theme: oxygen-gtk

re-select a GTK3 Theme: oxygen-gtk

and click apply...

Then every program include Firefox should appear correctly.

share|improve this answer
    
Apparently gtk3-engines-oxygen was already installed and also selected in GTK themes. Thank you, though. –  Richard Mar 13 at 14:43
    
Do you have such problems with other programs? Last time I have installed Kubuntu, gtk3-engines wasn't pre-installed and all my programs had similar problems. –  m1nev Mar 13 at 19:59
    
Yeah, the same thing happens with LibreOffice and a couple other programs like UNetbootin. –  Richard Mar 13 at 21:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.