Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Natty and my perfectly functioning Ubuntu has stopped working - specifically, it has stopped reading disks. I think the problem has to do with Disk Utility not loading (though Ubuntu can see USB and DVD drives, but not mount them), so I tried it through command prompt and got this:

sudo palimpsest
libgdu:ERROR:gdu-pool.c:2369:device_recurse: assertion failed: (depth < 100)

I'm not being lazy - I have now spent three days trying different things to fix it, Please Help!

share|improve this question
Can you add more information on what else you've tried? – Jorge Castro May 17 '11 at 12:20
have a look at this bug:… Problem seems to be related to the order of your partitions. It has some comments and tips on checking your system (fdisk -l). – Rinzwind May 17 '11 at 12:23

the problem is with ubuntu config,which is still not patched by canonical.So to avoid it you may have to degrade to 10.10

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.