Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed Ubuntu 12.0.4 LTS (Precise Pangolin). I tried to run sudo apt-get update on shell and it ends up with following errors after couple of seconds:

Err http://pk.archive.ubuntu.com precise Release.gpg
Could not connect to pk.archive.ubuntu.com:80 (58.65.218.244), connection timed out

W: Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/precise-backports/Release.gpg Unable to connect to pk.archive.ubuntu.com:http:

W: Some index files failed to download. They have been ignored, or old ones used instead.
share|improve this question
    
disable proxy by changing proxy method to none. –  Avinash Raj Mar 13 at 8:38
    
@avinash-raj Please use the code tag to highlight any code. Thanks –  Alvar Mar 13 at 8:44
    
goto setting click network and down there is Network proxy click it and make it none and apply system wide –  Rana Muhammad Waqas Mar 13 at 8:52
    
Thanks for your replies guys. –  Aziz Abbas Mar 13 at 9:09
    
I did do the same as suggested and then restart my machine and now I am getting following error if try to run sudo apt-get update E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable) E: Unable to lock directory /var/lib/apt/lists/ –  Aziz Abbas Mar 13 at 9:11

1 Answer 1

Open /etc/apt/sources.list and replace pk.archive.ubuntu.com with archive.ubuntu.com, after that save the file and run sudo apt-get update

share|improve this answer
    
Many Thanks, Problem Solved For me..You are the boss. –  Sizzling Code Sep 24 at 7:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.