Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently came across a problem and can't seem to find a solution in any forums. I recently attempted to compile enlightenment e18 from source. As I went along I took care of any dependencies that came about. However, after a while it became apparent that I could not do so from Ubuntu. So now, I have a broken package system that seems won't repair. Attempting sudo apt-get -f install gives me this output:

Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libeina-dev libevas-dev libevas1
Suggested packages:
  libevas-doc
The following NEW packages will be installed:
  libeina-dev libevas-dev libevas1
0 upgraded, 3 newly installed, 0 to remove and 232 not upgraded.
8 not fully installed or removed.
Need to get 0 B/1,483 kB of archives.
After this operation, 5,405 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 349556 files and directories currently installed.)
Unpacking libevas1 (from .../libevas1_1.7.7-1ubuntu1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libevas1_1.7.7-1ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/evas/utils/evas_image_loader.svg', which is also in package evas-generic-loaders 1.8.2~201401230955-1ppa1~saucy
Unpacking libeina-dev (from .../libeina-dev_1.7.7-1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libeina-dev_1.7.7-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libeina.so', which is also in package libefl 1.8.5~201401230949-1ppa1~saucy
Unpacking libevas-dev (from .../libevas-dev_1.7.7-1ubuntu1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libevas-dev_1.7.7-1ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libevas.so', which is also in package libefl 1.8.5~201401230949-1ppa1~saucy
Errors were encountered while processing:
 /var/cache/apt/archives/libevas1_1.7.7-1ubuntu1_amd64.deb
 /var/cache/apt/archives/libeina-dev_1.7.7-1_amd64.deb
 /var/cache/apt/archives/libevas-dev_1.7.7-1ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Attempting to do a repair from the Ubuntu Software Center gives me this:

installArchives() failed: (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 349556 files and directories currently installed.)
Unpacking libevas1 (from .../libevas1_1.7.7-1ubuntu1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libevas1_1.7.7-1ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/evas/utils/evas_image_loader.svg', which is also in package evas-generic-loaders 1.8.2~201401230955-1ppa1~saucy
No apport report written because MaxReports is reached already
Unpacking libeina-dev (from .../libeina-dev_1.7.7-1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libeina-dev_1.7.7-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libeina.so', which is also in package libefl 1.8.5~201401230949-1ppa1~saucy
No apport report written because MaxReports is reached already
Unpacking libevas-dev (from .../libevas-dev_1.7.7-1ubuntu1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libevas-dev_1.7.7-1ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libevas.so', which is also in package libefl 1.8.5~201401230949-1ppa1~saucy
No apport report written because MaxReports is reached already
Errors were encountered while processing:
 /var/cache/apt/archives/libevas1_1.7.7-1ubuntu1_amd64.deb
 /var/cache/apt/archives/libeina-dev_1.7.7-1_amd64.deb
 /var/cache/apt/archives/libevas-dev_1.7.7-1ubuntu1_amd64.deb
Error in function: 
dpkg: dependency problems prevent configuration of libecore-input1:
 libecore-input1 depends on libevas1 (>= 1.7.7); however:
  Package libevas1 is not installed.

dpkg: error processing libecore-input1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libecore-evas1:
 libecore-evas1 depends on libecore-input1 (>= 1.7.7); however:
  Package libecore-input1 is not configured yet.
 libecore-evas1 depends on libevas1 (>= 1.7.7); however:
  Package libevas1 is not installed.

dpkg: error processing libecore-evas1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libecore-dev:
 libecore-dev depends on libecore-evas1 (= 1.7.7-1); however:
  Package libecore-evas1 is not configured yet.
 libecore-dev depends on libevas-dev (>= 1.7.7); however:
  Package libevas-dev is not installed.
 libecore-dev depends on libeina-dev (>= 1.7.7); however:
  Package libeina-dev is not installed.

dpkg: error processing libecore-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libeeze-dev:
 libeeze-dev depends on libecore-dev (>= 1.7.7); however:
  Package libecore-dev is not configured yet.
 libeeze-dev depends on libeina-dev (>= 1.7.7); however:
  Package libeina-dev is not installed.

dpkg: error processing libeeze-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libecore-imf1:
 libecore-imf1 depends on libevas1 (>= 1.7.7); however:
  Package libevas1 is not installed.

dpkg: error processing libecore-imf1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libeet-dev:
 libeet-dev depends on libeina-dev (>= 1.2.0); however:
  Package libeina-dev is not installed.

dpkg: error processing libeet-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libecore-fb1:
 libecore-fb1 depends on libecore-input1 (>= 1.7.7); however:
  Package libecore-input1 is not configured yet.

dpkg: error processing libecore-fb1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libecore-x1:
 libecore-x1 depends on libecore-input1 (>= 1.7.7); however:
  Package libecore-input1 is not configured yet.

dpkg: error processing libecore-x1 (--configure):
 dependency problems - leaving unconfigured

I'm really stuck here, please help me!

share|improve this question

marked as duplicate by Avinash Raj, karel, Ask, Seth Mar 13 at 16:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

I found the answer at trying to overwrite '/usr/bin/opencv_haartraining', which is also in package libopencv2.3-bin 2.3.1+svn6514+branch23-12~oneiric .I wanted to thank everyone thats part of the ubuntu community for all your help!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.