Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I've been trying to get various distros Ubuntu running on my PC for a few months now, on and off. I recently had success with 14.04 on my Laptop so I decided to give it a go on my PC, especially because my PC is running fairly new hardware.

As it says in the title it doesn't quite work, it's a little laggy and there are a few graphical glitches. I tried to install nvidia-current and it seems as though the module causes everything to break. When I say everything, I mean I just get a blank screen with a blinking cursor. I can't even switch to a TTY, it doesn't seem to get that far. I can't even uninstall the module, I have to reinstall everything.

Here's the output of lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1)

So as you can see, it seems to think I have two graphics controllers? Here are my machine specs:

Motherboard: Gigabyte Z87-HD3
Processor: Intel Core i5-4430 (Haswell)
Video: GeForce GTX 660 Windforce

Is this a switchable graphics type deal? I tried installing the Intel graphics bundle but it's not supported on 14.04 yet so I tried installing individually and it didn't seem to have any effect. It shouldn't anyway because my video output is going though my nVidia card. I've had a look at the UEFI settings screen but I can't see anything of relevance.

share|improve this question

closed as off-topic by user68186, fossfreedom Mar 12 at 21:14

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – user68186, fossfreedom
If this question can be reworded to fit the rules in the help center, please edit the question.

    
It's not development version specific this has happened on multiple distros including 13.10 and 12.04LTS. It's to do with drivers and hardware compatibility, the fact that it's running on 14.04 is incidental. –  rich97 Mar 12 at 21:19
    
it is particularly important that you report these bugs otherwise the glitches cannot be fixed in the opensource drivers. Having to depend on the proprietary drivers does not benefit the wider linux community. –  fossfreedom Mar 12 at 22:19
    
He has Optimus technology and was using the Intel graphics for everything. This was not a bug or something. My answer solved his problems. –  Timpotim Mar 13 at 6:01
    
Well yes and no, I'm going to report it as a bug because I think the OS should be able to detect when you need to install these drivers. I didn't have the option in the additional drivers dialogue and the free alternatives weren't setup properly out of the box. –  rich97 Mar 13 at 12:09
    
That detection will probably be added in the 14.04 release. Optimus technology is a known issue. This is not a bug, just a shortcoming that's going to be fixed in the future. –  Timpotim Mar 13 at 13:50

1 Answer 1

up vote 2 down vote accepted

I think your computer has Optimus technology.

There are two solutions:

  1. Nvidia prime

    The binary Nvidia driver added partial Optimus support in the 319.17 update. You can install this by typing

    sudo apt-get install nvidia-319 nvidia-settings-319 nvidia-prime
    

    in the terminal to install the binary Nvidia driver. Prime will disable the Intel card, so you will only be using Nvidia. Nvidia prime is still work in progress and changing will be added. This works perfectly for me, and I have Ubuntu 14.04 with Optimus technology.

  2. Bumblebee

    The open-source project Bumblebee tries to provide support for graphics-chip switching. To install it, type

    sudo add-apt-repository ppa:bumblebee/stable
    sudo apt-get update
    sudo apt-get install bumblebee bumblebee-nvidia primus
    

    in the terminal. This works also very well. Before prime, I used this.

I hope this will fix the issue. If not, you can report this as a bug. Remember that Ubuntu 14.04 still is in beta stage.

EDIT: A flickering mouse: Mouse cursor flickering and disappearing

share|improve this answer
    
OK, I'll give it a shot. I'll let you know what happens. Wish me luck! –  rich97 Mar 12 at 22:04
    
Hey it worked! Have a gold star my man! –  rich97 Mar 12 at 22:08
    
You're welcome! –  Timpotim Mar 12 at 22:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.