Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Acer Aspire 6930G with an Nvidia 9600MGS and Ubuntu 12.04 LTS. Every time I turn off my computer and then turn it back on the brightness is always set back at the lowest possible level. I like to use max brightness but the computer keeps reverting back to minimum brightness after I turn it off.

I installed Ubuntu on this computer a week ago and this has been happening since the first day.

Can anyone offer some solutions? I've tried a few and none of them worked for me, that's why I'm asking here

share|improve this question
1  
Could you edit your question with links to the tried solutions? Otherwise people will answer with solutions you may have already tried –  Timothy Persoon Mar 12 at 7:31
    
There were a lot mainly from forum posts ranging from 2010 to 2011. I figured maybe the fixes I tried are outdated. I'm willing to try anything at this stage even if it is the same ting I have tried before. –  user257396 Mar 13 at 7:00

2 Answers 2

You could always try this:

edit /etc/rc.local to insert your preffered value:

sudo gedit /etc/rc.local

and add the following

echo X > /sys/class/backlight/intel_backlight/brightness

replace X by the value of your need

share|improve this answer
    
Alright I explored my sys folder and the chain goes: sys/class/backlight/acer-wmi/brightness. I changed what you said to read: echo 9 > /sys/class/backlight/acer-wmi/brightness and when I restarted and went to settings, the brightness bar was on full but the physical screen brightness was not. I clicked and dragged the slider back a bit and it instantly lit up. So to summarise; when I turn my computer on now the brightness bar appears on full but the actual screen illumination is minimum. Any suggestions? –  user257396 Mar 15 at 7:17

This is weird action from some Video cards to solve this problem you can do the following:

First let us check yiour VGA device code

lspci | grep VGA

The device code looks like 00:03.0 for example.

To set brightness

sudo setpci -s '00:03.0' F4.B='xy'

where 00:03.0 is your VGA device code && xy is hexadecimal value of your screen brightness varies between 00 and FF.

Now add this command to the /etc/rc.local file to run always on startup.

share|improve this answer
    
Hi, thank you for answering but can you please explain what you mean when you say 00 and FF? I don't understand what I am supposed to type there. I want the maximum brightness on the computer. –  user257396 Mar 15 at 2:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.